Sign in with
Sign up | Sign in
Your question
Solved

Z68 pro/gen 3 wont post, red cpu led on

Last response: in Motherboards
Share
December 11, 2012 2:07:30 AM

Hi all, was wondering if I could get some thoughts or if anyone has had similar proplems...


So I got an new Asus z68 pro/gen 3 to go along with a i7 2700k cpu. It will power up, cpu fan spins up, gpu fan spins up, but it won't post. It won't really do anything... No video. The red CPU LED comes on solid and it just sits there... sometimes it will reboot automatically after a few seconds, same thing though. I have not gotten it to post yet.

I have done all the trouble shooting I can think of and I'm at a dead end... I've cleared the CMOS, I've tried (known working) RAM in every single slot configuration there is. I've tried two PSU units, both known to be working, in fact I'm powering my back up PC with it now as I type!

I've re seated the CPU twice... with and without the back plate. I've re seated every power connection there is. CPU fan connection, ditto. I've tried with the mobo out of the case. In the case, all peripherals disconnected. The pins in the CPU socket look flawless.

I just can't think of anything else to do! I've read and researched this as much as I can (seems like it's a popular problem) and some people with the exact same problem either RMA their board, or it seriously like just magically works after awhile. It's the most bizarre and maddening thing!

Any ideas or thoughts of what else I can try? Do you think the CPU could possibly be shot!?

I don't know if this means anything, but I bought this mobo to replace an asus z68 deluxe that went kaput on me. I actually really liked that mobo, but one day I powered it on, walked away while it was booting up, came back, noticed it was off. I turned it on again, it it started to power up, but then just went completely dead... stayed dead for like three seconds, had a quick resurgence of power for like one second (lights fans all fired up again) then went completely dead. It did this every time I tried, so I got another PSU to test it out, and it did the same thing (started to power up, then just cuts off, dead for a few seconds, automatically surges back on for a brief second, then nothing)

So I explain that... because I hate to even ask, but do you think that could have killed my CPU? I've never had a CPU go bad before and just assumed the mobo was shot. Which is a shame because it wasn't even a year old. I wonder if there's anywhere I could take the cpu to get it tested...

Sorry for the huge post!

any and all ideas/opinions are appreciated!

Best solution

a c 150 Ĉ ASUS
a c 113 à CPUs
a c 557 V Motherboard
December 11, 2012 6:52:23 AM

Hi, Yes, it looks like a CPU issue. It doesn't happen often though, but a bad board can kill the CPU. A local shop might help, or simply RMA the CPU.
Share
December 11, 2012 7:51:19 AM

That's not exactly what I was hoping to hear... but it is in the back of my mind a possible reason/solution.

Bleh!

I've never had a CPU go bad in all my years of building. I've already put some inquiries around the Chicago-land area to see if anyone has a open test bench I can pop the CPU in. (I don't at the moment) I'll be really bummed if it is shot.

Can that really happen though? My second to last paragraph kind of explains how I got to this point, the previous mobo just went kaput out of the blue. No OC'ing, no new BIOS changes... it just happened. Is is really possible that event ruined my CPU?

The next question is... why did it work fine for nearly a year, and then POW!? Is it the mobo that caused it? I'm looking into the intel returns and it seems I should be covered under the three year policy. The CPU looks flawless. I'd be more amazed if it really is the cpu and not the mobo. Upon tons of research the board I just bought has maybe 1/10 negative reviews about the exact same problem I'm having. Solid red CPU led, no post.

It's so confusing! But thank you for your thoughts!
m
0
l
Related resources
a c 150 Ĉ ASUS
a c 113 à CPUs
a c 557 V Motherboard
December 11, 2012 10:05:57 AM

It is. Usually, the red CPU light is related to CPUs not supported by the board's BIOS, but that's not your case. The CPU is supported, and it should work, assuming it is correctly installed and the PSU provides the required power.
m
0
l
December 13, 2012 2:56:01 AM

Well thanks for the thoughts... the verdict is in... dun dun dunnnn.....

CPU is shot. I've never had a CPU go bad on me before so I was a bit incredulous about it. Microcenter had a wicked sale on them so I scooped up one of the last ones as a last ditch effort... darn thing posted right away and was up and running. Unbelievable!

I think I was quick to point to the mobo as the problem because so many searches revealed the same problem the the verdict an RMA. Glad I held on to it until I sorted out the very last thing I could not prove was working fine, the CPU.

Now to visit intel and learn more about their 3 year warranty! This chip didn't even last me a year! (yes I monitor the temps, speed, voltage, etc, NOT user error!)

Thank you for the help! I'm still shaking my head at a bad CPU, in all my years I've never had one fail on me! (or a mobo go nuts and suddenly fail, I'll never know if it was the culprit in killing it or not (it won't post with a spare I borrowed form a local shop)).
m
0
l
December 13, 2012 2:56:57 AM

Best answer selected by mzbo.
m
0
l
!