Sign in with
Sign up | Sign in
Your question

Sabertooth Z77 boot order issue

Last response: in Motherboards
Share
December 11, 2012 11:54:46 AM

Just built a new PC with the the Sabertooth Z77 board from ASUS, here are the specifics.

CPU: Intel Core i7-3770K
GPU: 2 x MSI N670 PE 2GD5/OC GeForce GTX 670 (SLI)
MOBO: Sabertooth Z77
RAM: 4 x 8 GB G.SKILL Ripjaws X Series 32 GB (F3-1600C9Q-32GXM)
HDs: Corsair Neutron Series GTX CSSD-N240GBGTX-BK 2.5" 240GB (new)
Seagate Barracuda 7200.11 ST3750330AS 750GB 7200 RPM 32MB Cache SATA 3.0Gb/s 3.5" (old)
DVD: LG 22X DVD+-R DVD Burner SATA Model GH22NS30
PSU: KINGWIN LZP-1000 1000W

Windows is installed on my SSD (Corsair) and boots fine when I select to boot from it in the BIOS. And the 750GB is formatted with nothing on it. The problem is the MOBO seems to ignore the boot order when booting up and boots straight to the BIOS where I then have to select the device to boot from. I've got the corsair plugged into S1, the HD into S3, and the DVD Drive into S5, but I've tried them in all sorts of different combinations with no luck. The only luck I have is when I have the other two SATA devices not hooked up.(750GB HD and the DVD drive), then it boots right to Windows from the SSD. I've tried disabling the other two devices in the boot order even without any luck. Any advice or help would be greatly appreciated, here's some screens from my BIOS.







Thanks in advance for any help!
December 12, 2012 1:36:09 PM

Some things to note, if I disconnect the HDD and the DVD drive, and have a bootable OS installed on the SSD, it boots fine from the SSD immediately. But as soon as I add the HDD or DVD, it doesn't boot from anything and goes straight to the BIOS. Also, if I turn off the PC and disconnect the AC power and plug it back in, it seems to boot fine for that one time (follows the boot order, not to BIOS unless I hold DEL), which made me think it was the fast boot setting throwing it off (since it's set to do normal boot after AC power loss). Tried turning off fast boot with the same results (boots to BIOS and have to select device).

Any advice would be greatly appreciated, I've gone through ASUS support and he's recommending me one thing a night via email and has come back to asking me if I have the boot order set correctly in the Advanced Mode BIOS. Could it be a bad board and should I RMA? Could it be that my DVD drive and HDD are older (purchased in 2009)? Or is it just a BIOS setting I'm not catching?
m
0
l
!