Sign in with
Sign up | Sign in
Your question
Solved

Ati Raedon HD 4670 driver crash issue

Last response: in Graphics & Displays
Share
September 10, 2011 10:16:29 PM

I recently purchased a n ATI 4670 as a small upgrade to my on board chip.

I'm using windows 7 x64 and every now and then i'll have random graphic drivers crash while playing games.....doesn't matter which whether it's minecraft or Assassins creed: Brotherhood

I've tried fixing it myself by reinstalled windows 7 and trying both older drivers and the newest and no matter what i do the drivers still crash.....there's nothing wrong with the card because it worked flawlessy on windows xp and so did the drivers.


Which leads me to believe it's an OS issue...however i can't stick with xp as a gamer since some games are unsupported for xp such as just cause 2.


Any help will be appreciated lemme know if you have any questions.
a b U Graphics card
a b $ Windows 7
September 10, 2011 11:14:02 PM

Have you disabled the onboard chip in BIOS?
September 11, 2011 1:19:00 PM

yes i always do
Related resources

Best solution

September 14, 2011 6:47:33 PM
Share

I believe it is windows 7 issue.

I have the same problem. I've been wandering around the web for 10 months; I have re-installed windows 7; I have tried all the drivers and catalysts; it's a shame.

I haven't test the card on Windows XP but many people say it works just fine as well.

Sometimes changing games settings to Medium/Low qualities appears to work. However it also crashes only with Internet Explorer or just the desktop.

Neither Microsoft nor AMD/ATI has attempted to fix this issue. And I am sure either of them doesn't want to assume the mistake.

Sapphire (Manufacturer) also sucks. They haven't responded to any email requesting support.

Please post any advancement.
September 14, 2011 6:59:23 PM

Try and find a Catalyst 9.x driver, I had that problem with my old sapphire HD4670 and using the 9.x driver worked flawlessly for me.

I believe 9.4 was the one I used.
September 15, 2011 3:20:37 AM

jossamah said:
I believe it is windows 7 issue.

I have the same problem. I've been wandering around the web for 10 months; I have re-installed windows 7; I have tried all the drivers and catalysts; it's a shame.

I haven't test the card on Windows XP but many people say it works just fine as well.

Sometimes changing games settings to Medium/Low qualities appears to work. However it also crashes only with Internet Explorer or just the desktop.

Neither Microsoft nor AMD/ATI has attempted to fix this issue. And I am sure either of them doesn't want to assume the mistake.

Sapphire (Manufacturer) also sucks. They haven't responded to any email requesting support.

Please post any advancement.



It has to be a windows 8 script error the 9.4 drivers do not work also.

(my card is an HIS.
September 18, 2011 6:50:22 PM

Best answer selected by halfchalupa.
!