Sign in with
Sign up | Sign in
Your question

ASRock Z77 Extreme6 Bios

Last response: in Motherboards
Share
December 12, 2012 6:45:16 PM

I noticed that the description in the 2.40 BIOS talks about VT-d

link here:
http://www.asrock.com/mb/Intel/Z77%20Extreme6/?cat=Down...

1. Support UEFI PXE boot.
2. Modify VT-d Capability will be unsupported after flashing BIOS P2.30.

Does this mean that VT-d didn't work in 2.30 and works with 2.40 or that this feature will no longer be supported at all?

I plan to run ESXi and want to be able to passthrough a video card and a SAS controller.
January 21, 2013 12:35:55 AM

I ran across the 2.30 BIOS after I updated while reinstalling Win7 64. Here's what I found: the VTd still worked, it just did not show up in the BIOS pages as a choice (along with VTi). I can confirm this, because I had my discrete video card connected directly to my monitor at the same time I had VirtuMVP enabled. If VTd didn't work, I would have had no monitor image at all. BIOS 2.40 fixed the user interface on the BIOS page, that's all. In sum, the functionality in 2.30 was always there.
m
0
l
February 3, 2013 7:36:48 PM

Are here any ASRock Z77 Extreme6 users with BIOS version >= 2.40? If yes, could you confirm whether VT-d works for you or not?
Could you also state whether you bought your mobo with such BIOS version or whether you upgraded it yourself? In case of the older BIOS: was VT-d turned on out-of-the-box or you had to enable it?

The info on the BIOS change version:
Quote:
Modify VT-d Capability will be unsupported after flashing BIOS P2.XX

could be in fact read as "turning off possibility to change its enable state" (after all these sites are known for bad English).

That would be perfectly fine assuming that VT-d was (when it was configurable in the BIOS) and still is (when it's not configurable in the BIOS) simply turned on by default. It would be bad in other case, though, because it would mean that only users who turned VT-d on before upgrade process can preserve this functionality and current buyers of this mobo (which most likely have recent BIOS) are without any hope.

(Naming mistake in BIOS hit me once (Abit KN9 virtualization naming), thus I started double or even triple checking many things in many cases.)

Untortunately, it's not clear, whether abel used BIOS version 2.40 in the end.
m
0
l
!