Sign in with
Sign up | Sign in
Your question

ASRock x58 Extreme PCI-E Issue

Last response: in Motherboards
Share
December 13, 2012 6:17:58 AM

So my computer has been working fine until a recent change... The motherboard is an ASRock x58 Extreme. The PCI layout looks like this:

--x1 PCI-E
----------------x16 PCI-E
--x1 PCI-E
-----------PCI
----------------x16 PCI-E
-----------PCI
----------------x16 PCI-E (Runs at x8)


I had two GTX 470s in SLI in the two x16 PCI-E slots and a wireless NIC in the top x1 PCI-E slot.

I just purchased an ASUS Xonar Essence sound card. I first took out the NIC and put the sound card there as it is also an x1 PCI-E card. Then I put the NIC in the bottom slot (a PCI-E x16 that runs at x8.) I booted up and installed the sound card drivers and it worked fine. However, the NIC was no longer recognized by the operating system and wouldn't work. Although, the green LED on the NIC was flashing on and off.

So, next I tried switching the sound card and the NIC's position. Now the NIC worked fine and the sound card wasn't working properly. The sound card was recognized after a few reboots and worked briefly, but caused the system to lockup whenever I used the sound for more than a few minutes.

So I have now taken out the top GTX 470 and am running both the NIC and the sound card in x1 PCI-E slots. They both work fine. But the glaring problem is... no SLI and only one GPU.

Any ideas? Thanks in advance!
a c 557 V Motherboard
December 13, 2012 7:56:06 AM

Hi, It might be related to the PCIe bandwidth.
Why don't you use the onboard NIC?
m
0
l
December 13, 2012 8:12:01 AM

Thanks for the reply.

The motherboard doesn't have built in wireless and that's what I connect with.
m
0
l
Related resources
a c 557 V Motherboard
December 13, 2012 8:52:06 AM

An option would be an USB Wireless.
m
0
l
December 13, 2012 6:34:49 PM

Yes, that would obviously be a work around, but I'm trying to diagnose the problem with the board so I can use all the devices.
m
0
l
!