Sign in with
Sign up | Sign in
Your question

2nd asrock z77 extreme9 faulty?

Tags:
  • Motherboards
  • ASrock
Last response: in Motherboards
Share
December 13, 2012 10:16:27 AM

G'day all,
I recently purchased an asrock z77 extreme9 with no hassles for a couple of months. Even had it o/c to 4.0 on air without any obvious problems (something my previous m/b couldn't). At the time I was running my dell u3011 with 2 gtx 670 4gb in sli and both dell u2711 on 2 gtx 570's. After some research I read that a single 570 could run both u2711's and figuring this would use less power removed one of the 570's and ran both u2711's from the one 570. It ran successfully for a few days and then stopped working all together. I replaced the (brand new) seasonic 1250w with a (brand new) enermax platimax 1500w but with no success. The pc would power up for a sec and then turn off. After more research I read that this was most likely the m/b. I just installed my 2nd asrock z77 extreme9 m/b only to have the same result. If anyone can shed some light on where I should venture next please let me know as I would greatly appreciate any assistance. It has come to my attention that not even the dr. debug lights up at all. I've just spent last 2 hrs trying different vid card/mem combinations but still no success.

My current specs:
asrock z77 extreme9
i7 2600k w/ noctua nf-p14 cooler
16gb ram 4x4 corsair 1600mhz 9-9-9-24
2 gtx 670 4gb
2 gtx 570 1.5gb
western digital 600gb velociraptor
western digital 150gb velociraptor
merc stealth
razer mamba 4g

More about : 2nd asrock z77 extreme9 faulty

a c 559 V Motherboard
December 13, 2012 11:42:38 AM

Hi, It might be a graphics card issue. Can you test with a different one? If still the same, then... the CPU?
m
0
l
December 13, 2012 11:56:51 AM

Thanks for the response. Unfortunately I've tried all four cards with no success. If my understanding is correct a single vid card always goes into the 2nd pcie slot with these boards?
m
0
l
Related resources
December 13, 2012 1:09:44 PM

i always thought single graphics cards go in the 1st 16x slot nearest to the cpu
m
0
l
December 13, 2012 1:27:27 PM

Just checked the manual and it states a single graphics card in pcie2 which is x16.
Contemplating upgrading cpu to the i7-3770k and hoping it works.
m
0
l
a c 559 V Motherboard
December 13, 2012 1:34:49 PM

Yes, the manual says that for single card, the PCIE2 slot has to be used. Have you tried the other slots? It might be a CPU issue then.
m
0
l
a c 490 V Motherboard
December 13, 2012 1:35:56 PM

sounds like something failed in your system and is shorting the system out and the power supply/mb see the dead short. i would try the mb outside the case with no ram or video card and see if it powers on and beeps at you. then i put in one dimm and see if the onboard video if it has it comes on. if not i use one video and see if the mb posts outside the case.
i would also check to see that the heat sink is not shorting the back of the mb.
m
0
l
December 13, 2012 2:36:32 PM

well i removed the mb to outside the case with only the power cables attached and still no luck. any other suggestions before i decide to upgrade. i'm thinking a new 2011 mb might be in order to go with a new 3930k or 3820k? any thoughts on a good mb to go with either chip? :) 
m
0
l
a c 490 V Motherboard
December 14, 2012 1:24:51 AM

for last shot try another power supply if you havent...
m
0
l
December 14, 2012 2:25:36 AM

I initially had a brand new seasonic 1250w and then tried a brand new platimax 1500w with the same result. even though i made sure to be careful when installing the chip, when i removed the chip to clean any excess thermal paste i noticed some pins had been bent, which is the reason i replaced the original asrock board. never had this problem with any other board. seems i'm after a new board after all. thanks for you advice guys
m
0
l
!