Sign in with
Sign up | Sign in
Your question

Won't POST: P8Z77 Pro + G.Skill F312800CL9D-8GBRL

Last response: in Motherboards
Share
December 15, 2012 12:45:22 AM

I just got my new build together and I can't get the it to POST. I was using this same RAM in my other build, so I'm pretty sure the RAM is fine. Also, I saw this make and model of RAM listed in Asus's QVL for this board. Not sure what to make of that.

Regardless, when I turn on the power the RAM LED comes on and stays on immediately. I used the MemOK feature, but the board still won't POST. I tried each DIMM in the suggested single slot, A2, but still no results.

I also tried swapping in some older Kingston HyperX KHX1333C7D3K3/GX. No change, same results.

Should I try BIOS Flashback? I'm not sure what that would accomplish since this is the first time I've powered the board. Kind of running out of ideas.

Really, really, REALLY hoping I didn't get a dead board...
December 15, 2012 2:20:28 AM

I didn't have the DIMMs pushed in all the way...

How embarrassing.

I partially blame Asus, though. They used to have DIMM slots with the movable clip on each side but now the clip is only present on the top side. The bottom just has a naked slot. Without the satisfying *click* of the clip, it can be hard to know if you've pushed hard enough...

Either way, pardon the n00b post, everyone. My bad.
!