Sign in with
Sign up | Sign in
Your question

Crysis 2 tearing, EVGA gtx 560 ti SC

Last response: in Graphics & Displays
Share
September 13, 2011 11:07:18 AM

Hi all,

I'm playing crysis 2 on 1920x1080 , dx 11, high res textures, and blackfire's mod all enabled on ultra settings

My system is the following:

-Phenom II x4 965 3.4GHz OC'd to 4Ghz
-4GB Gskill DDR2
-EVGA GTX 560 TI SC edition (stock 850 core/ 1700 shader / 2052 mem)
-650W Antec Earthwatts
-Gigabyte GA-MA790X-UD4P mobo
-Arctic Cooler freezer 7 pro rev 2

I have the most recent Nvidia drivers, and have overclocked my GTX 560 ti
to 950 core/ 1900 shader / 2152 memory and fan at 75%
which is in the 50-55C range in crysis 2. This newer overclock setting has been tested
in Furmark and is completely stable; however, Crysis 2 begins tearing with V-Sync enabled on these settings. I've lowered my OC to 900 core / 1800 shader / 2052 mem and crysis 2 plays fine with this.

Any ideas what's causing this??? I'd like to play Crysis 2 with my max OC listed above that's having the problems. All other games can play my max gtx 560 ti OC listed above fine with no tearing (witcher 2, dragon age 2, etc).

September 13, 2011 11:42:50 AM

If the game runs fine at lower settings then it's obvious the OC is the issue. Not all OC's are as stable as you think. Some games push cards harder than others and it seems to me the settings in Crysis 2 are stressing the card even with the OC causing problems. Only options are to either play with reduced OC or get a more powerful card.
m
0
l
September 13, 2011 11:56:43 AM

It is a bit strange since Futurmark is normally the highest possible Load on a GPU.
It "could" be an issue with all that diffrent mods that cannot cope with the OC parameters, but to tell you the truth, its very hard to guess.
m
0
l
September 13, 2011 4:31:05 PM

Go to nvidia control panel-->manage 3D settings-->turn to vsync and select Force On.Sometimes vsync option in games doesn't work properly.This does the trick for tearing for most of the cases.

m
0
l
!