Sign in with
Sign up | Sign in
Your question
Solved

XFX 6870 Black Edition not showing in Windows

Last response: in Graphics & Displays
Share
a c 104 U Graphics card
September 13, 2011 3:10:46 PM

Hello.
Other question about the 6870. ( don't think related to the other one )
I translate from a Dutch OS so please be patient.
I installed a XFX 6870 BE with latest XFX drivers but when i look in the resolution screen and then go to advanced settings the info about the gpu says the chip type is ATI display adapter ( 0x6738 )
The Dac-Type is internal DAC ( 400mhz )
Adaptertype 6800 series.
Is this normal or should it say Chiptype 6870 and internal dac 940 mhz or is internal dac something else than core speed. ( probably a nooby question but i really can't remember what it said with previous cards, i thought it always mentioned the max. core speed but not sure now anymore ) ( had an accident last week, my head is being a bit weird ) ( yes, even weirder than normal :pt1cable:  )
Btw catalyst overdrive says it's at 940 mhz and cpuid-z says it's a 6870, so everything is fine i assume ?
a c 226 U Graphics card
September 13, 2011 4:27:28 PM

What you are seeing is normal and nothing to worry about.
m
0
l
a c 104 U Graphics card
September 13, 2011 4:48:32 PM

You know that from experience, like you have one yourself or from a friend who has one ?
m
0
l
Related resources
a b U Graphics card
September 13, 2011 5:01:01 PM

Yes, I do have one, it's normal.
m
0
l
a b U Graphics card
September 13, 2011 5:07:54 PM

It SHOULD say 6800 series. Did you install the latest drivers from AMD.com?
m
0
l
a c 104 U Graphics card
September 13, 2011 5:14:08 PM

Oke, who's right then.
Geekapproved where exactly should it say that it's a 6800 series, on top of the window with the little gpu picture saying ; "Adaptertype" it says 6800 series but at the chiptype it says ATI display adapter ( 0x6738)
Did install latest drivers ( had to, this, probably litlle bit old, package only had a cd with no windows 7 drivers . . . )
m
0
l

Best solution

a c 226 U Graphics card
September 13, 2011 5:17:06 PM

The latest release from ATI/AMD is 11.8. The "6800 series" reference is perfectly normal. You have NOTHING to worry about. Just keep your system current and you'll have NO issues.

Good luck!
Share
a c 104 U Graphics card
September 13, 2011 5:25:15 PM

It states driver version 8.881.0.0 i believe. That is 11.8 i believe, because i got that from downloading and installing 11.8 from the site.
m
0
l
a c 226 U Graphics card
September 13, 2011 5:30:56 PM

GreenDutchAlien said:
It states driver version 8.881.0.0 i believe. That is 11.8 i believe, because i got that from downloading and installing 11.8 from the site.

You are good to go. Have fun!
m
0
l
a b U Graphics card
September 13, 2011 5:40:31 PM

GreenDutchAlien said:
Oke, who's right then.
Geekapproved where exactly should it say that it's a 6800 series, on top of the window with the little gpu picture saying ; "Adaptertype" it says 6800 series but at the chiptype it says ATI display adapter ( 0x6738)
Did install latest drivers ( had to, this, probably litlle bit old, package only had a cd with no windows 7 drivers . . . )


So what exactly is the problem?
m
0
l
a c 226 U Graphics card
September 13, 2011 5:45:34 PM

geekapproved said:
So what exactly is the problem?

Right. There is no problem. Only an issue of how different apps report the GPU model designation.
m
0
l
a b U Graphics card
September 13, 2011 6:10:29 PM

Ok, I though there was a problem. lol
m
0
l
a c 104 U Graphics card
September 13, 2011 6:12:21 PM

Right. Thanks a lot you all for the help, really eased my mind !
m
0
l
a c 104 U Graphics card
September 13, 2011 6:13:15 PM

Best answer selected by robjordy.
m
0
l
!