Sign in with
Sign up | Sign in
Your question

Realtek Network Controller not found

Last response: in Motherboards
Share
December 15, 2012 5:40:23 PM

I just built a new system and installed Windows 7 on my SSD. When Windows tried to authenticate itself it failed as it could not connect to the internet. Upon closer inspection of my Ethernet Controller device, its properties says that "The drivers for this device are not installed". I ran the LAN Realtek driver installation that came with the motherboard but received the error: "The Realtek Network Controller was not found. If Deep Sleep Mode is enabled, Please Plug the Cable".

I have tried removing my RAM and motherboard battery for 10 minutes, but that did not fix it. I've also resetted my UEFI BIOS but that did not work either.

Do I have a defected motherboard, or is there a step I am missing.

I want to note that prior to installing Windows 7 on my SSD, I ran MemTest86+ for several hours on my RAM. I also installed Windows 7 on another hard drive to run Prime95 for several hours. That hard drive that contains Prime95 + Windows 7 is not connected to the motherboard.
a b V Motherboard
a b $ Windows 7
December 15, 2012 6:52:22 PM

Some specs of your system, the mobo type for example would have been helpful here. Do you see the network controller with an exclamation mark in device manager?
m
0
l
December 15, 2012 7:01:15 PM

I am using an ASRock Z77 Extreme4. I see a yellow lock next to Ethernet Controller on the Device Manager window.

http://imgur.com/RNfA1
m
0
l
Related resources
December 15, 2012 8:02:20 PM

Stupid me, I didn't install my motherboard drivers properly last night. Must have forgot about it and assumed it worked this morning. Thanks for the help guys :) 
m
0
l
December 19, 2012 7:41:28 PM

I had the same problem with my win7 environment so I reinstalled using the cd that came with my motherboard. I opened the device Manager, located the network adapter right click -->selected Update driver software --> Selected the Browse my computer for driver software --> selected the drive where the cd resided and traversed down the path " \drivers\lan\lan\win7\64bit. " Installed without any errors.
m
0
l
June 12, 2013 10:58:09 PM

i too have the same problem with the ethernet controller....but to update the driver the adapter was not at all detected in the device manager....can u give mre the solution problem.....iam suffering with this problem since 2 weeks...
m
0
l
July 2, 2013 7:05:28 AM

enter BIOS, disable Green LAN.
hoangkien
m
0
l
!