Sign in with
Sign up | Sign in
Your question

ASRock Z77 Extreme4: only VGA works, no DVI or HDMI

Last response: in Motherboards
Share
December 16, 2012 4:27:21 AM

I have an ASRock Z77 Extreme4 mobo with a core i5-3570k cpu. Only the VGA port works, not DVI or HDMI. It's NOT a driver issue because it's not just Windows that has the problem, it's the BIOS too. I've upgraded the BIOS, and I've also RMA'd the board but the replacement has the same problem. I know that the monitor and video cables are good. The monitor is a Gateway FPD2185W.

Does anyone have a clue what might be the problem?
a c 431 V Motherboard
December 16, 2012 5:16:42 AM

Jim Shaffer said:
I have an ASRock Z77 Extreme4 mobo with a core i5-3570k cpu. Only the VGA port works, not DVI or HDMI. It's NOT a driver issue because it's not just Windows that has the problem, it's the BIOS too. I've upgraded the BIOS, and I've also RMA'd the board but the replacement has the same problem. I know that the monitor and video cables are good. The monitor is a Gateway FPD2185W.

Does anyone have a clue what might be the problem?

did you install the intel cpu chipset software from intel web site??? did you try the monitor with both the vga and dvi cables plugged in so that the intel software set the vga as monitor one and the dvi port as monitor 2??
December 16, 2012 5:33:41 PM

I've installed the Intel software. (Although this doesn't address why only VGA works in BIOS -- that's why I took the time to mention that.)

I have both cables plugged in. The Intel software only recognizes one monitor. However, the UEFI BIOS screen that gives you a picture of your motherboard and lets you identify the ports by clicking on them does recognize that two cables are connected.
Related resources
April 30, 2013 4:54:44 AM

I have a Gigabyte z77-d3h with exactly the same problem, and have seen other people with z77 mobos experiencing this as well, must be a fault with the chipset.
a c 554 V Motherboard
April 30, 2013 5:30:58 AM

The monitor has a DVI Video mode. Is it set to RGB Color Space?
July 23, 2013 7:24:31 PM

Jim Shaffer said:
I have an ASRock Z77 Extreme4 mobo with a core i5-3570k cpu. Only the VGA port works, not DVI or HDMI. It's NOT a driver issue because it's not just Windows that has the problem, it's the BIOS too. I've upgraded the BIOS, and I've also RMA'd the board but the replacement has the same problem. I know that the monitor and video cables are good. The monitor is a Gateway FPD2185W.

Does anyone have a clue what might be the problem?


Did you ever find a solution? I have a similar setup and am going through exact same thing. VGA works only. Onboard dvi does nothing, graphics card does nothing.
!