Sign in with
Sign up | Sign in
Your question

Issues with P8P67LE and Radeon 6850

Last response: in Graphics & Displays
Share
September 15, 2011 5:24:56 AM

Hey guys -

Desperate enough to finally turn to the internet to solve me problem. =P

So I've got a new rig going...

i7 2600k Sandy
2x 4GB G.Skill Sniper 1333Mhz
OCZ 120GB SataIII SSD
CoolerMaster Storm Scout

Looks like it's running dandy... except it's not.

So, I've got 2 motherboard and 2 graphics cards. I WANT to use my new XFX 6850 in my ASRock Z68 Extreme3 Gen3;

However, I couldn't get the damn thing to use the discrete card, not the integrate graphics. Even when I tried my old GT 240.

So I switched everything over to a P8P67LE that I also just purchased.

Same problems.... everything works, boots fine, loads up zippy quick with either card... right up until I reboot after installing the drivers. Then it gets to the Windows logo and locks up right before the login screen.

I've tried removing and reinstalling all of the drivers for either card several times on either setup... Anything I could've / did miss?

Thanks much

~John
September 15, 2011 6:41:55 AM

1st try to login in safe mode
then uninstaller drivers
the proble might be with the drivers get new correct version(drivers ) from the internet
normally this happen when the correct version of driver are not installed...
m
0
l
September 15, 2011 7:54:43 AM

usually there is option in BIOS to select integrated/onboard and pci-e video card
could be ram issue. try with 1 stick of ram, if problem try the other.
m
0
l
Related resources
September 15, 2011 10:37:17 AM

Alright,

So I've tried both of those solutions; First ran through my BIOS and doubled checked I have all the correct settings/

Also logging into safe mode and then uninstalling the drivers, works fine up to that point. Restarted, boots up and logs in without any drivers; then new software is detected, windows attempts to install some garbage, then I run the Catalyst installer thing; it finishes, then I restart again, same issue.

I feel like it might have something to do with UEFI and having a discrete card? That's the only similarity I can pick out that I've never encountered before.

Any more thoughts?

~John
m
0
l
September 15, 2011 12:33:49 PM

I haven't tried clearing the CMOS... probably should've thought of that. I'll try it out again and clear the CMOS too when I get home from work.

Did you use the newest drivers / did you install from the catalyst installer, or did you manage to just get the driver for the video card?

~John
m
0
l
September 15, 2011 2:40:33 PM

For clarification, the Z68 does not have integrated grapics, so that wasn't your problem.

Sounds to me like your memory settings are incorrect in bios. Check sticker on your dimms for correct voltage, speed and timings, then set those in bios manually.

This would cause all the problems you mentioned.

Also, if you didn't plug in the pci-e power cables to your video card, it's not going to work. And make sure your monitor is plugged into the video card after you connect it's power cables, not the motherboard.
m
0
l
September 15, 2011 3:32:06 PM

@Geek,
Bad memory timings may cause my issues, but they would also cause many other issues i'm not having, so i can rule that out.
My PCI-E cables are obviously plugged into my video card... or it wouldn't turn on at all.

@werner123,
Thanks for the advice, I def think I'm going to do that when I get home in a few hours... I'll post back when I get some results.
m
0
l
September 15, 2011 4:03:00 PM

I didn't say timings, I said timings, speed and VOLTAGE, especially. So your not even going to check...........lol
m
0
l
September 15, 2011 5:29:25 PM

I mean I can check again but I've already looked through them and I know they're correct. This isn't my first build.
m
0
l
September 15, 2011 11:12:27 PM

werner123 said:
Memory timings is automatically configured by the bios it's not necessary to manually do that, but it's worth a try.

And if nothing works as suggested format and reinstall windows.



I have only seen 1 out of 4 I have put together that do. Especially if you have ddr3-1600 at 1.65v it will default to 1.5v ddr3-1333 on auto. Mine actually defaulted to 1066. Same problem on my friends machine with DDR2. Her board was on auto which was 667/1.8v. She was having problems with it, I checked it was 800/2.0v ram that she had. I raised the voltage and speed and walah it worked perfect.

I also personally had a machine that would not load windows it would get a stop error. Same issue, the ram voltage wasn't high enough.
m
0
l
September 17, 2011 2:26:50 PM

Hey guys,

I eneded up erasing all the drivers I had on there, then reinstalling and updating the onboard ones to their newest settings ( i hadn't before ) and then installing just the 6850 drivers.

works like a dream.

Thanks for all your help, i really appreciate it!!!
m
0
l
!