Solved

Transcend 8GB 1333Mhz not working in DH67BL MotherBoard.

My system specifications are as follows:

Processor- I7 2600K @3.4 Ghz (SandyBridge)
MoBo- Intel DH67BL
Ram- 4GBCorsair XMS 1600Mhz
PSU- Cosrair 500W PSU
Graphics- Nvidia 9400GT.
OS- Windows 7 64 Bit

This configuration I was having earlier and It was working fine.

A few days back, I got some money and I wished to increase the RAM.
So I bought a single Module 8GB transcend 1333Mhz Ram. I removed the old 4GB corsair Ram and Installed 8GB single Module RAM. But when I started the system, nothing happened. Even the boot screen is not showing up. Just the monitor power LED is blinking. No kind of beep sound as usually comes due to RAM problem.

Also I updated the BIOS to the most recent version, by using the old corsair 4GB RAM. But Nothing seems to change, when installing transcend 8GB single module RAM.

But the Transcend RAM ,when I bought is a brand new one and it is sealed.

Need help on this.

Thanks
Muthu.
4 answers Last reply Best Answer
More about transcend 1333mhz working dh67bl motherboard
  1. Best answer
    Did you reset BIOS before starting with the new ram? New does not mean it cant be broken.
  2. No I didnt reset the BIOS. Please help me what to do now?
  3. rolli59 said:
    Did you reset BIOS before starting with the new ram? New does not mean it cant be broken.



    Thank you very much. I just Reset the BIOS and installed the new memory and It worked.
  4. Best answer selected by muthu3dtech.
Ask a new question

Read More

Memory RAM Motherboards