New build was working, then suddenly shuts off and won't turn on.

Got my new build working the other day if you read my first thread, and now while I was installing drivers for my pc, it suddenly shut off instantly causing me to open my case and to replug everything. Mobo is on and when I press the power button everything runs for a good second, so can you guys, the community help a fellow young builder out?
7 answers Last reply
More about build working suddenly shuts turn
  1. whats your power supply?

    its the most likely part that failed.
  2. Corsair Builder CX500 500W
  3. do you have another power supply you can try?

    the builder series are decent but are still not the best psus.
  4. I do not sadly, but here are the specs: Gigabyte GTX 550 Ti
    Intel i5 2500k
    Mobo- Asus P8H61-M LE CSM
    Corsair (2x2GB) 4GB
    Seagate Barracudaa 500GB
    Corsair Builder CX500 500W
    COOLER MASTER HAF 912 RC-912-KKN1 Black SECC/ ABS Plastic ATX Mid Tower Computer Case
    Intel Core i5-2500 Sandy Bridge 3.3GHz (3.7GHz Turbo Boost) LGA 1155 95W Quad-Core Desktop Processor Intel HD Graphics 2000 BX80623I52500
  5. try taking out the mobo battery to reset the cmos.

    can't really tell whats going on unless you can test the parts.
  6. Literally taking out the battery itself or just resetting the cmos?
  7. well if you have a cmos reset use it but if you don't taking the battery out and then putting it back 5 secs later also resets it.
Ask a new question

Read More

Power Supplies Drivers New Build Components