ASRock 970 Extreme 3 wont boot past bios

I've been having a lot of problems with this motherboard, and a new problem just popped up yesterday.

My computer was booting up all fine, and I was able to use it, but then it started to act strangely. It boots completely fine in Bios but wont boot up past that. I cant boot from DVD or HDD. It has a black screen with a little line blinking on the top left corner when I try to boot up from the DVD drive or HDD. Oddly enough, It recognizes my HDD and DVD drive in bios. What can the problem be? A faulty motherboard? Bad bios settings? Do I need to update bios?

Thanks!
8 answers Last reply
More about asrock extreme wont boot past bios
  1. Hi, Try disconnecting the HDD and inserting a known bootable DVD. See if it does boot. If not, disconnect the DVD and test with only the HDD.
  2. I had the same problem with this mainboard "ASRock 970 Extreme 3" plus FX-6300 and NVIDIA GT430 (1GD DDR3) + 8 GB RAM (2x4GB G.Skill).
    Upon system start it has a black screen with a little line blinking on the top left corner, though I have connected HDD and DVD (through SATA connectors).
    Then I reset the CMOS through jumper, and now it shows something like this:



    famicom95 said:
    I've been having a lot of problems with this motherboard, and a new problem just popped up yesterday.

    My computer was booting up all fine, and I was able to use it, but then it started to act strangely. It boots completely fine in Bios but wont boot up past that. I cant boot from DVD or HDD. It has a black screen with a little line blinking on the top left corner when I try to boot up from the DVD drive or HDD. Oddly enough, It recognizes my HDD and DVD drive in bios. What can the problem be? A faulty motherboard? Bad bios settings? Do I need to update bios?

    Thanks!
  3. There is no driver loaded, not even USB drivers e.g. no keyboard works, so pressing F2/Del doesn't show up any thing :(
  4. Try connectng the keyboard to a different USB port. Try a different keyboard, if possible.
    If still no go, then it might be a motherboard issue.
  5. Alright, my computer is now working. I unplugged the hard drive and dvd drive, put them in different slots, and then it started to work. It may not work for long though. I figured what i'll do is return this board because I've been having nothing but problems with it including usb and audio problems.

    To uetian:

    I have the same problem with the usb ports. The only thing that works, on mine at least, is a ps2 keyboard/mouse in bios.
  6. UETIAN said:
    I had the same problem with this mainboard "ASRock 970 Extreme 3" plus FX-6300 and NVIDIA GT430 (1GD DDR3) + 8 GB RAM (2x4GB G.Skill).
    Upon system start it has a black screen with a little line blinking on the top left corner, though I have connected HDD and DVD (through SATA connectors).
    Then I reset the CMOS through jumper, and now it shows something like this:



    famicom95 said:
    I've been having a lot of problems with this motherboard, and a new problem just popped up yesterday.

    My computer was booting up all fine, and I was able to use it, but then it started to act strangely. It boots completely fine in Bios but wont boot up past that. I cant boot from DVD or HDD. It has a black screen with a little line blinking on the top left corner when I try to boot up from the DVD drive or HDD. Oddly enough, It recognizes my HDD and DVD drive in bios. What can the problem be? A faulty motherboard? Bad bios settings? Do I need to update bios?

    Thanks!



    Also have this problem right now
  7. Marcopolo123 said:
    UETIAN said:
    I had the same problem with this mainboard "ASRock 970 Extreme 3" plus FX-6300 and NVIDIA GT430 (1GD DDR3) + 8 GB RAM (2x4GB G.Skill).
    Upon system start it has a black screen with a little line blinking on the top left corner, though I have connected HDD and DVD (through SATA connectors).
    Then I reset the CMOS through jumper, and now it shows something like this:



    famicom95 said:
    I've been having a lot of problems with this motherboard, and a new problem just popped up yesterday.

    My computer was booting up all fine, and I was able to use it, but then it started to act strangely. It boots completely fine in Bios but wont boot up past that. I cant boot from DVD or HDD. It has a black screen with a little line blinking on the top left corner when I try to boot up from the DVD drive or HDD. Oddly enough, It recognizes my HDD and DVD drive in bios. What can the problem be? A faulty motherboard? Bad bios settings? Do I need to update bios?

    Thanks!



    Also have this problem right now


    I had to replace the motherboard. Went back to the shop and told the salesperson that MB has some problem, they simply tested it, and gave me a new 970 Extreme3. Everything works perfectly fine now.
  8. ok ...
Ask a new question

Read More

ASRock BIOS Boot Hard Drives Motherboards