Sign in with
Sign up | Sign in
Your question

Failed to boot after bios update

Last response: in Motherboards
Share
December 18, 2012 11:53:23 PM

Hi, the other day my wifi stopped working on my laptop(HP Pavilion-g (g6-1b22ca), running Windows 8 that I updated to) and after some research it seemed that that best thing to do was to update the drivers. I looked on the hp website and found that almost all of my drivers were outdated. I downloaded all of them and started with the one at the bottom the list which happened to be the bios. After it installed the bios, Windows would not boot. I can access the bios and it says it's at the correct version, but when I get to windows booting, it tries, then shows the repair screen. I have tried with two drives, and it does the same thing. But when I try to boot off the second drive when it is in an external case, it works. Both drives can be accessed from another computer when in the external case.

Thank you, UberFefa.

P.s. I know (now) that Updating the bios isn't a good idea unless there is an issue.
December 19, 2012 12:05:28 AM

sounds like new bios confused your existing I/O drivers that windows uses. If you can get it to boot with external drive update the I/O drivers that hp provides, if not an update try to reinstall the drivers. also see if a windows update may be available for this issue
m
0
l
December 19, 2012 1:00:52 AM

What do you mean by I/O? Bios? The problem is, when I load up windows on the external, it gives me a bunch of file path missing errors on a lot of things, including device manager, and all the driver files.
m
0
l
Related resources
December 19, 2012 4:05:12 AM

I/O meaning the drivers that handle drives and the like. It says the path is wrong because when you are booting with external drive it is not assigned same drive letter as the internal boot drive. You may try to reassign the drive letter and then reboot. Windows is nasty about not letting you reassign a drive letter when that drive contains the system files. You may have to get out the recovery disc here as well.

Let me think for a sec here. How much experience with this kind of stuff do you have? It is good to know so I can give you the best advice.
m
0
l
a c 558 V Motherboard
December 19, 2012 4:30:47 AM

Hi, Check the SATA setting. If AHCI, switch to IDE and test. If IDE, swith to AHCI.
m
0
l
December 19, 2012 12:39:30 PM

I am pretty tech savvy, I like computers, and I like to fix computers, and generally I'm pretty good at it, but this one had me stumped.

As for the recovery disc, I just upgraded to 8 a few weeks ago, and I used a USB. I tried putting that in the other day, but it just did what it normally did, fail.

As for the SATA settings, my BIOS doesn't let me touch those -I can't even see them.
m
0
l
a b V Motherboard
December 19, 2012 12:51:53 PM

Hi,

Have you tried to reset bios to default ?
m
0
l
December 19, 2012 4:18:01 PM

Yes, many times, and I even reset CMOS by removing the battery. It even said "CMOS Reset"
m
0
l
December 20, 2012 12:34:33 PM

Any other ideas?
m
0
l
!