Sign in with
Sign up | Sign in
Your question
Closed

Slow USB write - fast read.

Tags:
  • Windows 7
  • USB
Last response: in Windows 7
Share
January 8, 2010 2:44:28 PM

Hello,

I have read many threads on this forum about slow USB transfer speeds in Windows 7. I'm starting a new thread because my problem may be different, and I've been able to consolidate all of the advice in those threads.

When attempting to write to any USB drive I have connected (including a 1GB USB key and a 1TB Eagle Consus S-ATA Raid0) I initially see the transfer going very quickly as Windows 7 caches the transfer. The speed initially goes to 60MB/s and then the bar stops moving. If I wait, the transfer never completes with a 1GB test file.

I cannot cancel the transfer, since it says Cancelling but never completes. Only a reboot or disconnecting my drive stops the transfer process. While attempting to transfer, any attempt to read from the drive stalls as well.

Read speed is normal. I can access files on the drive, and copy from the USB -> Windows 7 at full speed.

Here are the things I have done to fix the problem:

1) Set the drive to Performance Mode to enable write caching.
2) Uninstalled and re-installed the USB Root Controller and Intel USB Controller devices.
3) Upgraded to the latest Intel Device Drivers.
4) Ensured that my USB ports are 2.0, and that I am connected to the rear powered USB outlets.
5) Installed the Windows 7 hotfix intended for NVIDIA chipsets with 4GB RAM (does not apply to me, but tried anyways).
6) Tried formatting in 16K block sizes instead of 4K or 8K.

When I connect either USB device to my Macbook Pro, with NTFS drivers installed, my read and write speed are normal. For that reason, I know that the problem is not with my USB drives.

Tonite I will try an Ubuntu live CD to see if I can get full speed write with the exact same hardware that Windows 7 is using, to rule out that this is somehow a hardware issue.

Thanks in advance for anybody who might be able to help.

More about : slow usb write fast read

a b $ Windows 7
January 11, 2010 11:26:30 AM

Check your Windows 7 Device Manager for badly installed devices.
Score
0
January 11, 2010 2:12:52 PM

There are no badly installed devices in Device Manager. I went through the devices and removed and reinstalled them just in case as well.
Score
0
Related resources
a b $ Windows 7
January 11, 2010 3:10:38 PM

In Device Manager > Disk drives, right-click the USB drive
select Properties > Policies tab
choose Optimize for performance
Click OK to keep it
Score
0
January 11, 2010 3:15:56 PM

Hi Gandalf. I really appreciate your help, however if you read my initial post you'll see I already set the drive to performance mode. I've already been through anything that has already been suggested in these forums.
Score
0
September 8, 2010 1:16:33 PM

I had the same problem but to me the only solution is Total Commander , 3x's faster transfer ... Try...



micko

Serbia
Score
0
a b $ Windows 7
September 9, 2010 1:45:24 AM

This topic has been closed by Mousemonkey
Score
0
!