Sign in with
Sign up | Sign in
Your question
Solved

Unable to Get Port 3389 Open and “Seen” for Remote Desktop

Last response: in Networking
Share
December 13, 2010 2:43:34 PM

Unable to Get Port 3389 Open and “Seen” for Remote Desktop (from iPad over Fios Router to XP Laptop)

I am working to get remote access to my corporate laptop from my iPad using remote desktop.
• Laptop – Running Windows XP SP3, my corporate IT folks have turned on Remote Desktop.
• Router – My home network has a Fios Actiontec MI424-WR (revE) router, and I have turned on port forwarding for 3389, pointing to the IP address of my laptop on the home network (192.168.x.x).
• iPad – The iPad is running Mocha Remote Desktop (RDP), where the configuration requires only the IP and port; I have configured with the external IP address for my router, and port 3389.

I am able to connect with remote desktop when the iPad and laptop are both on my local network at home. But when the iPad is on an external network, it fails to connect and times out.

I have tried setting up Dynamic DNS on the router (created a DynDNS account, entered the xxx.dyndns.org host name in the router settings, and tried pointing the iPad’s remote desktop app to xx.dyndns.org) but this also failed to connect and timed out.

(I can not try Remote Desktop with another port, as I can not make admin changes to the corporate issued laptop.)

Here are some of the rudimentary diagnostics I have checked:
• Listening – When I run ‘netstat –a’ from the laptop, it shows that the machine is listening to port 3389.
• CanYouSeeMe – When I test for port 3389 using CanYouSeeMe.org on the laptop, it reports that it can not see my service on Port 3389.

Why would port 3389 show as forwarded on the router settings, be show as listening from the laptop with netstat –a, but not be “seen” with port testing? What am I missing to be able to connect from outside of my own network?

Best solution

December 13, 2010 4:52:58 PM
Share

It's got to be a router setting. Check, double check, and triple check the port forward. Is it running TCP and UDP?

Also, is your laptop on a static IP? A lot of people overlook this when they setup port forwards. You MUST have the laptop on the SAME IP every single time you setup a port forward. Port forwards do not carry over to other DHCP addresses.
December 13, 2010 5:05:44 PM

I think it's the router too. And I'm hoping someone on the forum has had a similar issue.

I've been trying it till my eyes can't stay open. TCP, UDP, and "both".

I've tried with the laptop on it's default dynamic IP from the router (but without a reboot) as well as giving it a static assignment (although it's 192.168.x.x assignment was always pretty stable).

Appreciate the suggestions...keep 'em coming!



Psychoteddy said:
It's got to be a router setting. Check, double check, and triple check the port forward. Is it running TCP and UDP?

Also, is your laptop on a static IP? A lot of people overlook this when they setup port forwards. You MUST have the laptop on the SAME IP every single time you setup a port forward. Port forwards do not carry over to other DHCP addresses.

Related resources
December 13, 2010 5:27:41 PM

quincycat said:
I think it's the router too. And I'm hoping someone on the forum has had a similar issue.

I've been trying it till my eyes can't stay open. TCP, UDP, and "both".

I've tried with the laptop on it's default dynamic IP from the router (but without a reboot) as well as giving it a static assignment (although it's 192.168.x.x assignment was always pretty stable).

Appreciate the suggestions...keep 'em coming!



No problem, I just setup RDP for external access as well from my rig at home. Yay Facebook at work! XD

Anyways, are you using your external IP address to access your computer? If not, you will need to type in your external IP address to access RDP over WAN. If you don't know what your IP address is, go to www.whatismyip.com to see.

You can also test this from home, the traffic to request the RDP session will be sent out to the ISP and back to your network as if you were at work.
December 13, 2010 5:52:18 PM

So I have the Remote Desktop App (for the iPad) pointing at the external IP for the router (displayed on the router settings page and confirmed with whatismyip).

Just a footnote -- when I am on my local network, I can connect if I point to 192.168.x.x (the local IP for the laptop). But even on the local network, I fail to connect if I point to the external IP.

(Kudos on FB @ Work. My company opened up to social media & FB earlier this year, a turn that surprised most of the 100,000+ employees.)
December 13, 2010 6:09:11 PM

Does your router have a DMZ? Try putting your laptop in the DMZ and see if you can connect there. This will rule out issues with port forwards and router config (hopefully).
December 13, 2010 6:31:35 PM

I put the laptop in the DMZ (using it's local network IP) and tried to connect with just about any IP address -- the router's external IP, the laptop's IP...but nada (except still able to connect from within the local network when pointing to the laptop's local IP). What's your interpretation?
December 13, 2010 6:37:03 PM

I hate to be a pain in the ass but can you send screenshots of the following settings?

1.) NAT
2.) Port Forwarding
3.) Reserved IP addresses on the router
December 15, 2010 12:38:53 AM

Hard to consider your question a P.I.T.A. when you are jumping in to help.

Here are my port forwarding settings (I do not have any settings for NAT, and everything is with a dynamic IP range so nothing locally has a reserved IP [although I did try assigning to the laptop and it still failed]):


December 25, 2010 12:42:25 PM

Best answer selected by quincycat.
September 19, 2012 1:10:51 AM

I'm running windows 7 Ultimate 64 bit, and this worked for me:

Try going to RUN and type "services.msc" hit ENTER. There are 2 services you want to look for: "Remote Desktop Services" and "Remote Desktop Services UserMode Port Redirector". Right click on each one seperately and select "properties", then change the startup type to "automatic". Restart your computer and then check to see if your port if listening properly, or try your RDP program again.

I looked through forums for days and no other solution worked for me except this one. I hope it works for you as well.

Good Luck.
November 9, 2012 12:19:21 PM

Visit the website http://portforward.com/ in order to get detailed instructions regarding opening Port 3389. Also, you can use various remote support services such as logmeinrescue, gosupportnow etc. in order to access computers remotely.
!