USB Ports Not Working

I installed an asrock N68C-GS FX a week ago and the only problem im having is none of the usb ports are working so i cant get a mouse or keyboard working! ive tried the old kind of keyboard and mouse with the green and blue plugs but that didnt work either. The only other thing ive noticed is the led in the power light isnt turning on and i dont know if thats related or not. If anyone knows whats wrong or what could help please let me know because im really getting frustrated.
6 answers Last reply
More about ports working
  1. Go into the BIOS and make sure the the onboard USB controller is enabled and that the USB legacy function is enabled. These settings should be in Integrated Peripherals. As fas as the power led, try reversing the lead that connects to the motherboard, it seems as though you have it backwards. The little triangle, on the lead, should be to ground (-).
  2. thanks you were right about the power button led but how do i go into bios if i cant get a keyboard to work?
  3. Did you try all of the ports even the ones on the front of the case?
  4. yup tried em all and nothing
  5. ok i found something that i think might be the problem i was reading through the manual and decided i would try resetting the cmos and in the manual it showed a jumper on both on usb pwr1 and usb pwr2 but neither has a jumper!Could this be the cause of the problem??????
  6. That might be the problem. Put jumpers on them and see if it works....
Ask a new question

Read More

Motherboards USB Keyboards