Sign in with
Sign up | Sign in
Your question

Dual Boot RedHat 7.2 and Win2K/ME

Last response: in Linux/Free BSD
Share
December 11, 2001 5:27:35 AM

Hello Linux guys!
I've got a dual Win2k Pro/WinME machine. I wanted to install Linux on it for the first time(RedHat 7.2). As I had only 2 x 10 GB partitions on my HDD each for one OS(20 GB Quantum Fireball AS) I used Partition Magic 7.0 to make them smaller(now 2 x 7GB) and then used the 2 unallocated spaces(2 x ~3GB) in the Linux installation to make my EXT3 and SWAP partitions (one as /boot and one as / and swap). Everything from PM 7.0's resizing my disk to Linux setup and using GRUB to multi-boot went [seemingly] smooth(I was happily working with Gnome). But then I restarted to load Windows. I used the Win2K/ME option I'd created on GRUB and the original boot menu(choice of 2K and ME) came up. WinME happilly booted but Win2K? It didn't even reach the Starting Windows 2000 text-based page and told me right away that: my NTOSKRNL32.EXE file is missing or corrupted! Damn! The file was INTACT and RIGHT WHERE IT SHOULD HAVE BEEN(in winnt\System32 folder)! To make a long scary story short I managed to screw the Linux partitions within Windows 2000 setup :-( and also restore the MBR with the recovery consule. Then I quit the setup process and everything is now working as it did (besides the unallocated space remaining like that 'cause I'm eager to try another time) WHAT IN THE NAME OF HELL HAPPENNED?! Why one of my friends (only Win2K server) didn't have similiar ones? What about that WRONG error message I got booting the 2K pro?
Help is most appreciated...

More about : dual boot redhat win2k

December 12, 2001 1:02:08 AM

Hmmmm...This is a tough one.
I think the fundamental problem relates to Win2k not liking being kicked off the MBR. So, if all your data is gone, I got a plan for ya':
Format Hard Drives like such:
7 GB FAT32 WinME
7 GB NTFS Win2k
5.5 GB ext3 (or whatever floats your boat) /
500 MB swap
Now install WinMe. Then install Win2k to D:. Make sure you can boot both.
Now, install Linux on the third partition. You don't need a /boot. If anything, I would recommmend making a /home partition.

Install Linux as usual, but choose LILO instead of grub. Make sure your LILO is configured such that boot=/dev/hda3 and root=/dev/hda3 (they are the same).

Boot into your LInux system using a boot floppy. Make sure you have a blank, formatted floppy on hand. After the system boots, remove the floppy and replace it with the blank floppy.
Now, execute the following commands:
$ su
Enter root password: ********
# mount -t msdos /dev/fd0 /mnt
# dd if=/dev/hda3 (Your Linux root partition) of=/boot.bot bs=512 count=1
1+0 records in
1+0 records out
# cp /boot.bot /mnt
# umount /dev/fd0

Now, boot into Win2k. Put the boot.bot file directly in your D: drive (where Win2k lives). Now, edit your boot.ini file in Win2k so that it includes the following line at the end:
D:\boot.bot = "Redhat 7.2"

Now, when you boot you should get the NT boot manager. Try booting all 3 OS's...Best of luck.
Y

"If you teach a child to read, then he or her will be able to pass a literacy test" - George W.
December 13, 2001 10:53:54 AM

so haven't figured out grub ethier

i tried it and when i tried to put a new kernel in and couldn't find out how to do i was heck wih it and refromated it.

lilo is much more well known so it is easier to get help onit is pretty easy to learn to use

<font color=red>Gasoline + Fire</font color=red><font color=green> Can be a lot of fun</font color=green> :smile: :smile: :smile:
Related resources
December 15, 2001 8:28:52 AM

Thank you for all the info Red_Zealot!
Actually I didn't lose my FAT32 partitions last time [thank God!] but I used Partition Magic 7.0 to make them 2x7.5 GB FAT32 ones (with no unallocated or EXT partitions in between) and will be using the remaining ~5 GBs for EXT3 (/) and SWAP. Also I'm done with ME so I only installed Windows 2K clean on C yesterday (BTW last time, I had installed ME on C and 2K on D).
Tonight I'm going to try it another time BUT armed with your info. Wish me Good Luck!
December 15, 2001 1:06:08 PM

Mandrake 8.1 has troubles w/ a 512 byte boot sector...If everything works OK, ie you can select Linux and then the screen goes blank or something, try it again but using a 768 byte boot sector...It should work fine then.

"If you teach a child to read, then he or her will be able to pass a literacy test" - George W.
December 17, 2001 7:19:59 AM

I didn't have the time to install Linux then. Although, I had a question: Do I configure LILO to use and overwrite MBR or first sector of boot partition?
December 17, 2001 6:25:49 PM

NO...don't overwrite the MBR..That's where the NT boot loader lives.

"If you teach a child to read, then he or her will be able to pass a literacy test" - George W.
December 19, 2001 8:50:48 AM

Whew I FINALLY DID IT :-)
I got the chance to also install it on a friend's computer which had WinXP on C. I tested both ways: I successfully applied your advice to my computer and used GRUB on his: Both worked flawlessly and we are both running RedHat 7.2 now (but with different boot loaders). I think the real problem with my config had been the hectic allocation of HD space to different file systems and OSes (WinME on C, /boot, Win2K on D, / and SWAP) Because despite overwriting the MBR in the case of my friend's PC (only XP on C, now also with / and SWAP) nothing wrong happenned and XP still boots up all right.
I had planned to post this message from Linux; Alas I can't connect via Linux :-( I've got a F***ING 56K software MoDem!
Anyway thank you again Red_Zealot: I'm currently learning about the shell and am trying to understand exactly what you did with those commands!<P ID="edit"><FONT SIZE=-1><EM>Edited by r2k on 12/19/01 07:01 PM.</EM></FONT></P>
Anonymous
January 8, 2002 3:08:45 PM

I'm having a problem that sounds similar to this but enough different that the advice already given here doesn't seem to apply.

I have w2k/ntfs on an existing 20 GB drive. I added a shiney new 40 GB drive, as slave, to install mandrake 8.1. The two drives are attached through an ultra 66 ATA controller card. When I try to boot from the madrake install CD, the system hangs after displaying a screen or so of text output about the devices it has found. The last thing on the screen deals with the drive where w2k/ntfs is installed. When I remove the w2k/ntfs drive and make the new drive master, mandrake installs and runs just fine. If I add the w2k/ntfs drive back in as slave, mandrake boot up hangs similar to the install hang.

As a side benefit, the mandrake install hang often corrupts the w2k/ntfs system (I'm stubborn, I've tried it about 6 - 10 times using different drive connect configurations).

Could this be an ntfs incompatability, ATA controller card problem, or ???

Thanks for any ideas.
!