Sign in with
Sign up | Sign in
Your question

Dolby Digital live not working in Windows 8

Last response: in Windows 8
Share
January 17, 2013 10:17:13 PM

Well, I recently installed Windows 8, installed all the latest drivers for my hardware. I have a Sound Blaster X-Fi Titanium, and while the drivers clearly sort of work (I am getting sound out of my S/PDIF optical out), Dolby Digital live does not work - I'm stuck in 2-channel mode, converted to PrologicII by my receiver. The sound is the same for music and non-HD video as it was in Windows XP (with the exception that when the card is not outputting any signal to the receiver, the receiver's mode switches to Stereo - once I play a file the receiver switches back to Prologic). When I play an HD file the receiver switches on Prologic, instead of Dolby Digital. I have tried intalling and playing one game (Deus Ex: Human Revolution), and got no sound at all. I am installing Crysis 2 (yeah yeah, I'm behind the times - good games are still good after a year, and so much cheaper!) and will try that when it's done.

Oddly enough, going into the Windows device manager to view the encoders shows that DDL and DTS Connect are active, and when I use the test button, the appropriate lights come on on the receiver and I get the test tones.

Any suggestions?
January 17, 2013 10:28:23 PM

Just tried Crysis 2, and I'm getting sound, but still Prologic, no DDL
m
0
l
January 18, 2013 4:41:46 PM

I assume the system is set up for 5.1? Might just be (another) odd Creative driver bug. You can give the PAX or Daniel_K driver packs a try and see if you have better success with them.
m
0
l
Related resources
April 7, 2013 5:58:14 PM

I don't know if this will help this dude in particular, but I beat my head against a wall for two days straight trying to get true 5.1 surround in games through my Creative Sound Blaster Recon3D Fatality Champion using SPDIF Out. I finally stumbled upon success. I'm not even sure what exactly did it, but since I haven't seen this distinction posted anywhere, figured I'd do so here. First key element: make sure the Creative Control Panel works, meaning you can see the options not just a blank skin (I couldn't at first, it took multiple uninstalls and re-installs before I could. It may have had to do with my turning off all virus protection while installing and downloading drivers, not sure). Go through all the options and choose what makes sense (Dolby Digital Live, Surround as 100% to get more from the rear, and Stereo as a Digital Mix to get killer music, for me). Second key element: DO NOT disable "Speakers" in Windows Sound Control (I have Windows 8) thinking "SPDIF Out" should be enabled and not "Speakers". THEY BOTH NEED TO BE ENABLED. And, ironically, "Speakers" has to be the "default device" even though the default device in fact is whatever you have hooked up to "SPDIF Out". Hope this helps. Wish someone would have posted this for me a couple days ago. Almost sent my card back. Now everything sounds awesome.
m
0
l
April 9, 2013 5:31:00 AM

^^ Oh yeah; I thought that little "feature" was well known by now.

Just a FYI, when "SPDIF Out" is selected as the default output device, Windows treats ALL audio sent over SPDIF as uncompressed stereo. ALWAYS have "Speakers" selected as the default output device.
m
0
l
!