Sign in with
Sign up | Sign in
Your question

ACPI (BIOS) configuration for windows 7/shutdown ends without turning off the co

Last response: in Motherboards
Share
December 21, 2012 8:53:49 AM

Hello,

I have a desktop with ASUS P5KPL-CM motherboard, 4GB DDR2 and intel E7300 CPU.
Shutdown, sleep and hibernate worked fine with WINDOWS XP.
When I upgraded to WINDOWS 7 64bit, the follwing problems appeared:
1. Shutdow ends consistently without turning off the computer power (fans continue to work and front green led continue to lit). It looks like the shutdown process is indeed shuting off all services and no signal is sent to screen but fans/led are not powered off
2. sleep & hibernate seem to work BUT immediatley (less than a second) after the computer is "sleeping", it get back to normal mode and wakes up even if network cable is disconnected and wireless mouse is turned off.


Note that I installed the last bios firmware and all ASUS board drivers.

I suspect that it's somehow related to ACPI configuration in the BIOS or to a jumper settings on my motherboard.

Regarding problem #2: when I configure the mouse and keyboard drivers (via device manager/power management) to disable waking up the computer by this device, the immediate wake up problem is solved.
However now I cannot wake up from slep by usig either muse or keyboard. It used to work fine with my previous windows XP installation.

The two problems appeared immediately after installing a fresh windows 7 ultimate (before any updtes or additional installations).
Both problems continues after all windows updates and driver installations/updates.

Thanks a lot for your help.


December 21, 2012 12:48:25 PM

Do you see any driver conflict errors in the Device Manager? ACPI stands for advanced configuration power interface and helps dole out IRQ addresses and even allows for some hardware components to share IRQs.
m
0
l
December 21, 2012 2:42:07 PM

No, I don't see any error in the device manager. The only warning that I have is a yellow triangle on the "Microsoft PS/2 Mouse" device, stating it's not connected (which is true since I have a wireless logitech mouse).

I assume my problem is related to power configuration since windows is not controlling power down properly.

BTW, my current power configuration in the BIOS is:

Suspend mode: Auto
ACPI 2.0 support: disabled
ACPI APIC support: enabled

This is the default BIOS configuration.

Another issue that may be related to my sleep problem is that for both my keyboard and mouse devices in the device manager, there is a check-box in the power management tab "Enable computer to turn off this device to save power".
This option is grayed out and unchecked for both devices.
m
0
l
Related resources
December 21, 2012 10:32:14 PM

I'm happy to announce that I managed to solve the problem.
Although my motherboard does not have a firewire port, I had a IEEE1394 Bus host controller device.
I changed its setting in the device manager to allow the computer to switch off the device (going to properties of the devices under IEEE1394 Bus host controller and going to power management. After that, make sure the "allow this computer to turn off this device to save power" is ticked).

This solved the shutdown problem - now it turns off the power at the end of the shutdown process.

BTW, after a few shutdowns (I checked that it's consistent), the IEEE1394 Bus host controller device disappeared from the device list. I don't understand how this happened but this device should'nt been there at the first place since my board does not support firewire. Anyway, shutdown continues to work properly.


m
0
l
May 22, 2013 5:33:24 PM

I have the same problem Telco has at shutdown with my sleep. Sometimes when I tell my pc to sleep the screen powers down but the fan assumes high speed and just runs the leds stay on also I have to then hold in the power button shutting it down and loosing all my started tasks and/or windows. also the issues came up afer going from vista to 7 on my gateway m6849 notebook. I don't have a firewire port but the controllers aren't installed either
m
0
l
!