Sign in with
Sign up | Sign in
Your question

ASROCK P67 Gen3 Audio Problems

Last response: in Motherboards
Share
December 21, 2012 6:48:23 PM

Hey guys so I recently had to reformat my PC. I reinstalled all of my drivers from the ASROCK website. This is including the 100ish mb Realtek audio drivers. After my restart, I still don't see Realtek HD Audio Manager like I used too. Also the audio jacks/optical audio jack does not work... I can get a USB headset to work though.

It seems Realtek HD Audio manager is gone and I can't find my Motherboard disk. I tried the Realtek website and the ASROCK website for drivers, but none of them seem to include the Realktek HD Audio Manager software.

Again, my motherboard is the ASROCK P67 Generation 3 and my operating system is Window 7 64bit. I think that is all you would need to know about my specs.

Thanks! :) 

Update: So today I realized that 'Realtek HD Audio Manager' does not even show up in my Device Manager at all. I also read that I need to have 'UAA' in my System Devices but I don't have that either. I think that may be what is causing my issue. Does anyone know how to get 'UAA' on Windows 7??

Update2: I tried everything I possibly could and nothing really worked. I decided to RMA the board through ASrock. We will see how this goes...
a b V Motherboard
December 21, 2012 7:08:59 PM

An important info about your system is missing! Do you have a hdmi port on your graphic card? Then right click on the volume icon in the taskbar, goto playback devices and switch the standard back to realtek. You will see the HD Audio-Manger pop up in the taskbar after A restart.
December 21, 2012 7:12:38 PM

I do have an HDMI output on my video card. I will take a look when I get home to see if this is the solution.
Related resources
December 23, 2012 6:58:50 PM

The only thing that comes up in playback devices is my USB headset. There is nothing else there to select.
January 1, 2013 8:08:12 AM

Ok so I recently noticed that Realtek HD Audio does not even show up in my device manager. I did some research and it seems like I may need MS UAA? I don't see that in my device manager either and I have tried to download it quite a few times.
a b V Motherboard
January 1, 2013 7:07:53 PM

Maybe the onboard audio is disabled in bios?
January 1, 2013 9:50:46 PM

I looked and it says Auto and the front panel is enabled.
!