My asrock 970 extreme 3 bios won't recognize my optical drive

I need to install windows 7 but my optical drive doesn't show up in boot priority. Help please! : /
6 answers Last reply
More about asrock extreme bios recognize optical drive
  1. Check the data cable on your optical drive, or replace with a different one to see if it works.
  2. knightdog56 said:
    Check the data cable on your optical drive, or replace with a different one to see if it works.


    Okay, the data and power cables are secure. So I guess the problem is either that my optical drive is DOA, or that my data cable is faulty? Which do you think is the more likely problem? Should I just order a new optical drive?
  3. What is the make and model of your optical drive ? Also does the LED on the optical drive light up when you insert a disk into it. Also check in BIOS under storage configuration SATA Mode (AHCI Mode) is enabled. Connect optical drive to SATA port 5.
  4. knightdog56 said:
    What is the make and model of your optical drive ? Also does the LED on the optical drive light up when you insert a disk into it. Also check in BIOS under storage configuration SATA Mode (AHCI Mode) is enabled. Connect optical drive to SATA port 5.


    It is a Lite-on DVD Burner Model: iHAS124-04-OEM

    It does not light up when I insert a disk because it does not open to allow for the insertion of a disk. Also, I just followed your advice and plugged it into SATA port 5 and set the storage configuration to AHCI Mode. Still nothing : / The bios says it does not detect any SATA device in port 5, although it is detecting my Seagate 1Tb Hdd in SATA port 1.
  5. Sounds like a bad optical drive, a while back I used Lite-On but switched over to ASUS and have not had any problems for the last three years, maybe you were just one of the unlucky ones to get a bad one.
  6. knightdog56 said:
    What is the make and model of your optical drive ? Also does the LED on the optical drive light up when you insert a disk into it. Also check in BIOS under storage configuration SATA Mode (AHCI Mode) is enabled. Connect optical drive to SATA port 5.


    I have the same problem, thank you. I enabled SATA Mode (AHCI Mode)
Ask a new question

Read More

Chipsets BIOS ASrock Optical Media Windows 7 Motherboards