Sign in with
Sign up | Sign in
Your question

PC won't boot after new PCI USB3 card. Troubleshooting tips, pls!

Last response: in Motherboards
Share
December 21, 2012 11:15:17 PM

I have a desktop with an ASUS K8V-VM mobo, prob 5 yrs old.

I recently bought a PCI-E USB3 card , so that I could use my new USB3 external HD at top speed.

I installed the card in the one empty PCI-E (x1) slot in the PC.

When I switched the PC on, the fans started (and I think the internal HDs spun up), but:
- there was no video signal sent over DVI,
- the keyboard LEDs didn't light up,
- and I didn't even get the beep that signals the BIOS self-test has worked OK.

I removed the card, everything worked fine. Whenever I switched the PC on with the card installed, the PC didn't boot far enough to get anywhere useful.

I then tested a PCI-E SATA card in that same slot. The PC booted normally with that installed.

So I returned the USB3 card to Amazon and bought another, but now the replacement is doing exactly the same thing. It's possible I've had two faulty PCI-E cards, but it seems more likely there's something wrong with my setup.

I have a 650W PSU, (that on Amazon has four 1 star reviews). Maybe it's the PSU?
Or is there some known incompatibility between certain mobos and PCI cards?

Or has anyone got suggestions for what to troubleshoot? I've got a picture of my available settings in BIOS, if that helps and there's a link to the kind of PCI-E USB3 card I've got at the start of the post.

Other bits:
The card has a molex connector, which tried with it connected and not connected.
Can't see how it's relevant, but I'm running XP with an AMD processor.

Thanks, Richard
December 25, 2012 9:30:04 AM

Any thoughts, anyone?

Any PSU experts out there?

Thanks, R.
!