Sign in with
Sign up | Sign in
Your question

Hard Drive Access Problem

Last response: in Components
Share
February 17, 2012 12:46:13 AM

Ok, I have a strange one for anyone that can help out.

I recently have been having problems with accessing files on a HDD. It first happened about a week ago. Computer starts up as normal just fine but as soon as Steam, which runs off a separate drive, tried to run, it would attempt to load the program and go no further, no connecting account window or anything, yet it was running as a process in Task Manager. Also, loading anything else off the same drive would be extremely slow, and sometimes would have the same problem, in that it would start to load, but stop mid process. I attempted to back up files so I didn't have to redownload/install everything off that drive (particularly SW:TOR as it is a 20Gb download), but I was unable to copy anything from the drive. chkdsk came back with no errors.

I formatted the drive and my main drive and reinstalled windows, steam and a couple of games. Initially, everything was running fine, but a couple of days ago, the same problem began to occur. Steam not loading, unable to run programs from the drive. I blocked steam from startup, ran registry cleaner tools and a disk checker, and again, no errors. I then attempted to run steam. It didn't run, and when I checked in processes, it wasn't there. So I attempted to run Steam again, to which it told me the drive wasn't there. Sure enough, in explorer, the drive was missing.

On restarting the PC, chkdsk ran, found a whole heap of file index problems and took a good couple of hours to fix them. Upon finally restarting, I ran HD Tune for an error scan, which comes up clean. This time at least I am able to copy files from the drive, however, trying to copy an entire folder and in some cases, more than a single file, and the drive doesn't cooperate at all.

The only changes that were made to the PC in both cases of this occurring were Windows Updates. I hesitate to believe that Windows Updates are causing this problem, else you'd think I would find MANY cases of this occurring after the update, as it would likely not be an isolated case.

I am considering doing a zero fill erase of the drive, but I'm curious to see if anyone out there can make any sense of my predicament. I hesitate to think that this is an actual drive issue, considering no tool I've used has come back with actual hard drive problems. Not to mention I don't see why it would copy individual files without problem, but not be able to move all the files in the folder.

PC Setup
Intel i7 2600k
ASUS P8Z68-V LX (latest bios installed)
2x 4Gb G-Skill F3-12800CL9 RAM
ASUS HD6970 DCUII 2Gb
2x WD Black SATA3 HDD (one of these is the drive in question)
1x Seagate SATA HDD
Windows 7 Ultimate
February 17, 2012 9:43:30 AM

How old your hard drive is?
m
0
l
February 18, 2012 1:48:32 AM

Drive is only 3 months old.

I tried to do a zero fill on the thing and it wouldn't cooperate, so I guess it's off to RMA land for me.

After the zero fill failed, it's now coming up with SMART issues.
m
0
l
!