Automatic IP not working

I have a Toshiba laptop. For some reason it does not want to accept automatic IP assignments on the LAN. It will take manual assignments. All software is up to date. Everything looks OK.
Any suggestions.
3 answers Last reply
More about automatic working
  1. Is DHCP enabled on your router?

    Are you experiencing this problem with your own network, someone else's, or does it not matter what network you're on?
  2. Quote:
    Hi Rich

    Go to cmd prompt and enter the following

    ipconfig /all

    copy and paste it here



    Windows IP Configuration

    Host Name . . . . . . . . . . . . : Artist
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Hybrid
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No

    Wireless LAN adapter Wireless Network Connection 2:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft Virtual WiFi Miniport Adapter
    Physical Address. . . . . . . . . : 06-26-B6-EE-22-22
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes

    Ethernet adapter Local Area Connection:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Atheros AR8152 PCI-E Fast Ethernet Controller (NDIS 6.20)
    Physical Address. . . . . . . . . : 00-26-6C-5A-98-B5
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes
    IPv4 Address. . . . . . . . . . . : 192.168.2.55(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.2.1
    DNS Servers . . . . . . . . . . . : 208.67.222.222
    208.67.222.220
    NetBIOS over Tcpip. . . . . . . . : Enabled

    Wireless LAN adapter Wireless Network Connection:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . : Belkin
    Description . . . . . . . . . . . : Atheros AR9285 Wireless Network Adapter
    Physical Address. . . . . . . . . : 00-26-B6-EE-22-22
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter isatap.{1A795B6B-00A7-45DE-822B-92DEDA5ABA09}:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft ISATAP Adapter #3
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 9:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes
    IPv6 Address. . . . . . . . . . . : 2001:0:4137:9e76:2091:25c1:3f57:fdc8(Preferred)
    Link-local IPv6 Address . . . . . : fe80::2091:25c1:3f57:fdc8%15(Preferred)
    Default Gateway . . . . . . . . . : ::
    NetBIOS over Tcpip. . . . . . . . : Disabled

    *******************************************************************************************

    Answers to questions:

    DHCP is enabled as far as I know. Now that is something I wouldn't know where to activate---not that famular with W7 yet.
    When I am on-line, I am the only device active. I have no problems with the other 2 PC's, or the IP printer.
  3. I forgot to add DHCP Service is running.
Ask a new question

Read More

LAN Laptops IP Toshiba Networking