Sign in with
Sign up | Sign in
Your question

XFX Radeon 6970 is undetected.

Last response: in Graphics & Displays
Share
September 20, 2011 5:38:46 AM

A couple weeks ago I bought a new 6970 to replace my old card, a 5870. When I first put in the 6970 nothing worked - I got no visual, the fan ran full blast, and i got a beep code from my mobo that said it wasn't detecting any video card. I contacted XFX to see if it was my card, and they thought it was so I sent it in. Nothing was wrong with it but they sent me a replacement anyways. That one doesn't seem to be detected either. Could it be my PSU? It's a 650 watt PSU which worked fine with my 5870 and i read that the 6970 actually uses slightly less power. The PSU only has 2 6 pin power cords though and no 8 pin - not sure if 8 pin is required or not.

Anyways help would be appreciated. I also should mention that I updated the bios on my mobo(Asus P6X58D Premium)and made sure the latest drivers were installed for the GPU and still nothing.
September 20, 2011 11:29:30 PM

Did you install the drivers for the card? How about removing the drivers for the previous card?
m
0
l
September 21, 2011 12:40:40 AM

Did the card also come with a molex adapter? Try that out before giving up on it.
m
0
l
Related resources
September 21, 2011 3:22:36 AM

it did not come with any adapters and yes i did remove the previous drivers and install the drivers off the CD they gave me. i still get the same beep-code and no visual output at all.
m
0
l
September 21, 2011 4:04:13 AM

Make sure you're plugging in the proper power cables to the card. I believe you'd need at least a 6 pin and an 8 pin power connector for that card. Correct me if I'm wrong. It also may not be booting because your PSU is insufficient. What PSU are you using?

You need the 6 pin and an 8 pin. Get a 6 to 8 pin adapter. It should work fine.
m
0
l
September 21, 2011 4:42:17 AM

Like i said earlier i am using a 650 watt ULTRA PSU with NO 8 pin connector. I should have tried getting an adapter to begin with... I guess I thought it was fine because I was told the wattage would be fine. Kind of a noob move on my part I guess! I'll try that and let you know the results. Thanks for the help so far.
m
0
l
!