Sign in with
Sign up | Sign in
Your question

ASRock Z77 Extreme4 not recognizing one SATA hard drive

Last response: in Motherboards
Share
December 24, 2012 5:48:11 AM

I have just recently upgraded my motherboard to an ASRock Z77 Extreme 4 and I'm having problems getting one of my disk drives (Seagate ST31000340AS) to be recognized by the system. Here are the particulars:

* Motherboard: ASRock Z77 Extreme 4, BIOS version P2.40
* OS: Fresh install of Windows 8 onto a new SSD
* All drives are SATA
* Multiple other drives from my previous computer are working just fine
* One drive in particular (Seagate ST31000340AS) is not recognized by Windows at all. It doesn't show in Windows Explorer and doesn't show in the Manage Disks application.
* That Seagate drive worked fine with my old motherboard.
* That Seagate drive works fine now with a SATA --> USB adapter so I can access the drive just fine via USB, just not through the motherboards own SATA which I guess means that it works fine with the adapter's SATA controller.
* I have tried the drive in multiple SATA ports and with multiple SATA cables, including SATA ports and cables that work fine for other drives.
* I have tried the drive in both SATA2 and SATA3 ports on the motherboard.
* The drive is powered (I can hear it and it gets warm), but will not get recognized by Windows.
* Both SATA controllers on the motherboard are set to AHCI.

Any idea what I can do to troubleshoot further or figure out why the mobo doesn't like this drive?
December 24, 2012 7:10:05 AM

Latest bios is P2.70
Intel RST is 11.6.0.1030 or 11.7.0.1013

m
0
l
December 24, 2012 7:38:33 AM

kpo6969 said:
Latest bios is P2.70
Intel RST is 11.6.0.1030 or 11.7.0.1013
I looked at the changes since 2.4 here http://www.asrock.com/mb/Intel/Z77%20Extreme4/?cat=Down... and the changes have either to do with UEFI PXE boot, with USB compatibility or with VT-d support. It didn't seem worth upgrading the BIOS when there are no changes listed that seem relevant. Make sense?

Intel RST is not enabled in the BIOS (don't know what version is installed).
m
0
l
December 26, 2012 6:12:16 AM

After lots and lots of internet searching, I found the problem. It was this thread http://windows8forums.com/windows-8-rtm-support/13384-w... that showed me the answer.

Windows 8 won't allow you to have a second drive on it with an extended partition (it refuses to boot when it finds that condition). I don't really understand what an extended partition is (or why this drive ever had one in the first place), but when I mounted the drive through USB via an external SATA/USB converter and looked at the drive in the most excellent (and free) EaseUS Partition Tools, I could see that this drive did, indeed, have an extended partition. I used the EaseUS tool to convert the extended partition to a primary partition (while preserving all the data) and wa la, Windows 8 would boot with the drive present and now sees the drive with the drive mounted in a normal internal SATA port. Problem solved.

As it turns out, one other issue that was complicating my detective work is that one of my SATA ports on my motherboard seems to not work reliably (I think a connector issue). Anyway, by avoiding that SATA port and by changing the partitioning on the drive, I can now use the drive in Windows 8.
m
0
l
!