Sign in with
Sign up | Sign in
Your question

Using ICS on a wireless connection

Last response: in Wireless Networking
Share
March 18, 2011 5:02:15 PM

Hello,
I have a Dell (Latitude D620) with a wireless connection and a RJ-45 network connection. I use my wireless for my internet connection, and want to allow other computers (on the wired network) to share my wireless internet connection. The problem is that all forums I have found merely say "click the enable connection sharing checkbox". This is not helpful, as that option is not available on my wireless conn. It is available on the wired conn. I also received a message saying that the connection wizard can only be run as network administrator. I have a home network...I am all the administrators. What is one to do in this situation?

I am using Intel PROSet/Wireless for my wireless connection.

Can anyone help?

thanks
a b F Wireless
March 18, 2011 6:23:24 PM


Your Wireless Connection Properties should show an Advanced tab to find that check box. However, the ICS Service is shared by Windows Firewall so if you're using a different one, you may not see that tab.

m
0
l
March 18, 2011 6:30:28 PM

Not sure I understand the response. I right-click on my connection. Then I click the Advanced tab. Here, I have only Windows Firewall. I do not have the ICS choice. I am using windows firewall, in fact, when I click the settings for firewall, the radio button for "Off" is grayed out. If I could change the windows firewall settings, would I then be able to set up ICS?
m
0
l
Related resources
a b F Wireless
March 18, 2011 6:38:09 PM


It's possible but that greyed out feature is sometimes an indicator of a lower level User Account in XP. Restart and tap Function 8 then log in Safe Mode with Networking as Administrator. That account is a higher level than those with administrative privilges accounts in Normal Mode.

m
0
l
March 18, 2011 6:55:55 PM

Well, I booted up in Safe Mode, as Administrator. The firewall options (On and OFF) are still grayed out. I went to windows firewall from control panel, same results. Is there anyway around this?
m
0
l
a b F Wireless
March 18, 2011 6:58:36 PM


Sounds like a Group Policy setting. Was this ever part of a large network?

m
0
l
March 18, 2011 7:02:16 PM

No, not part of a large network, or any network for that matter. I put in a new hard drive, installed win xp, and here I am. I will examine group policies, but am out of time for today. I will check in over the weekend.
Thanks!
m
0
l
March 22, 2011 1:13:19 PM

I am still no closer to a solution.
I have Intel rather than windows managing my wireless connections. Would that make a difference?
m
0
l
a b F Wireless
March 22, 2011 1:31:05 PM


I always let Windows have supremacy or it's likely to spit its dummy out and spoil things. Well worth a try. Is eth Wireless Zero Configuration started and set to Automatic?
m
0
l
March 22, 2011 2:10:22 PM

The Wireless Zero Configuration service is set to automatic, but not currently started. I do see thye Intel wireless services (4 of them) are automatic and running. I will switch to windows management of wireless, and see what happens. A little busy at the moment, should get to it this afternoon.
thanks!
m
0
l
March 23, 2011 11:31:40 AM

OK, so this morning, I set it up so that windows manages my wireless. I rebooted into safe mode (with networking) as Administrator. The sharing option is still not available. WZC is automatic and started. I also noticed that I could not turn the firewall off or on, grayed out. Also noted that above that it said that "for your security, some settings are controlled by Group Policy". Ever notice that the things you want to do, but can't is for "your protection" or "your security"? Anyway, I still cannot share my wireless connection. Any other ideas? This is my computer, how can I control Group Policy?
m
0
l
a b F Wireless
March 23, 2011 6:27:22 PM


Start>Run type in gpedit.msc and hit Enter. Look for settings which seem restrictive and amend them.

m
0
l
March 23, 2011 7:21:34 PM

So many settings....so little time....
I now know how to adjust Group Policies. Thank you for that.
Navigating through all this is the next challenge. I see many settings under Admin Templates>Network>Network Connections. I monkeyed around and seem to have altered what I see in the properties panel. The Advanced tab is gone.
I think I need a little more direction.
For example, I see "Prohibit access to the Advanced Settings item on the Advanced menu", which I disabled (seemed like the right way to go). But then I saw that disabling or not configuring has the same effect.
Anything additional you can tell me?
m
0
l
April 5, 2011 3:49:35 PM

Well, I waited for more information, then was busy on other projects. If there is nothing more you can tell me, let me know. If you can help guide me through these settings, great, I appreciate all the help I can get.
thanks.
m
0
l
a b F Wireless
April 6, 2011 7:00:20 AM


Sorry but I'm away on holiday with only Linux for company. Someone with access to a Windows system will doubtless chip in and help you out.

m
0
l
December 10, 2011 1:39:24 AM

I had the same problem. Essentially, you can't share an internet connection off a laptop that gets its internet wireless-ly. The "router computer" needs to get its internet through a LAN cable then use the wifi card to broadcast a computer-to-computer (adhoc) network. This network is setup in the wireless connection settings by ADDING a network with a SHARED network authentication setting. Then click the checkbox at the bottom that says "this is a computer-to-computer (ad hoc)..." Now go into your LAN SETTINGS and under ADVANCED share the WIRED connection. LONG STORY SHORT: YOU CAN'T SHARE A WIRELESS INTERNET "SOURCE," ONLY A LAN "SOURCE."
m
0
l
!