Sign in with
Sign up | Sign in
Your question

ASRock H77 PRO4-M USB Power Issues

Last response: in Motherboards
Share
December 25, 2012 11:04:37 AM

Hello!

I've just bought a new PC.

CPU: Intel Core i7 3770 3.4 GHz
Mobo: ASRock H77 Pro4-M
PSU: nJoy 600WRX 600W
RAM: Geil Dragon Ram 8GB DDR3 1600MHz CL11 Dual Channel Kit
HDD (older): Samsung HD 502IJ - 500GB

I have some issues regarding my USB ports/hubs. Somehow they don't deliver enough power.

I had Windows 8 at first and I couldn't plug anything into the motherboards USB ports because they simply didn't work (mouse/keyboard lights remains off). I plugged them into the case USB front ports and they worked just fine.

I thought it was broken and I sent the mobo back to the shop. They sent it back and told me they tested it on W7 / Linux and everything was just fine.

I then installed Windows7, the drivers from the CD and they worked only a little bit.

I tried different ways of plugging the mouse and the keyboard into the 4 ports from behind and if I plug more than one device into those ports I get a windows notification saying that somehow the hub cannot power so many devices.

I looked over the internet and I think something is wrong because I don't plug more than one device into an USB port.

Does anyone know how can I fix this issue or give me any hints?
December 30, 2012 9:56:40 AM

After many struggles I found the problem and fixed it. There were to many motherboard holders mounted on the cases and one of them was shorting the USB ports. Removed them and everything works just fine.
a b V Motherboard
December 30, 2012 11:10:42 AM

Might want to check if it caused any damage.
!