Sign in with
Sign up | Sign in
Your question

Surface RT RDP client won\'t connect to 2008 R2 RD Gateway

Last response: in Windows 8
Share
January 17, 2013 11:59:25 PM

I have an RD Gateway (TS Gateway) running on 2008 R2 server at our office. Windows XP and Windows 7 both connect through the gateway just fine. I also have apps on my Kindle Fire, Win8 Phone and boss's Android phone that all work.
I have already found out that with Windows 8 you have to modify the group policy for RDP connection to TCP only. It won't work using UDP. I tried it and the tweak works.
However, we are testing with Surface RT (running Windows RT) and can't get it to work.
MS Tech Support for the Surface told me it won't work and I should return the Surface RT and spend $300 more for a Surface Pro running Windows 8 Pro. Has anyone else had this problem?
More specifically, has anyone fixed this problem? I suspect there should be a registry hack to make the RDP client for Windows RT to use TCP Only and not use UDP. Does anyone know how to do this?
Thanks,
Dan
January 22, 2013 8:04:44 PM

Update: Turns out MS Tech Support was incorrect. You can use MMC to install the group policy snap-in. Then you can edit the RDP connection method like you do with Windows 8. I tested it and it works. I am surprised MS support would give me such bad information. My first call they suggested using logmein and the second time they suggested I buy a Surface Pro. Go figure.
m
0
l
February 1, 2013 4:00:27 PM

OK, so it turns out you CAN run MMC on a Surface RT and install the Group Policy Object Editor. Then you just need to go to
Computer Configuration - Administrative Templates - Windows Components - Remote Desktop Session Host - Connections and select RDP transport protocols.
Enable that and change it to TCP Only.. Then it should work.
m
0
l
!