Sign in with
Sign up | Sign in
Your question
Closed

Help!!! V-Sync Issues

Last response: in Graphics & Displays
Share
September 22, 2011 4:52:36 PM

I have a Radeon 6670 1G DDR5, and a 23 inch Samsung 1080p LCD Monitor, 60 Refresh rate.

On some games that don't have the option to enable V-Sync, i see image tearing at both high and lower resolutions. The one im current trying to play trough is the Witcher 1 EE. It doesn't have the option to enable V-Sync, and when i go directly to the GPU's menu and enable it it doesn't seem to work. When i boot up the game i still see image tearing. How can i fix this, this also happens to me with some other games that i own. How come Star Wars" KOTOR 1 supports v-Sync, when it's old as hell, but The Witcher 1 EE Doesn't?

P.S have the latest Catalyst Update 11.8

More about : sync issues

Best solution

September 22, 2011 6:32:54 PM

Some developers are too lazy to add in a Vsync option, either that or they think their game is so demanding that no hardware available at the time of launch will do much more than 60FPS. You can try to force Vsync for all applications through the Catalyst Control Center in the gaming graphics section, but that doesn't always work. The other option is to download Rivatuner, it comes with a tool called D3DOverrider. You can use that tool to force vsync for specific applications. Simply open it up, add the Witcher exe to the list, and select the option to force vsync. Simply keep D3DOverrider minimized and launch the game, and it should cap your framerate to 60FPS.
Share
September 22, 2011 7:19:49 PM

Supernova1138 said:
Some developers are too lazy to add in a Vsync option, either that or they think their game is so demanding that no hardware available at the time of launch will do much more than 60FPS. You can try to force Vsync for all applications through the Catalyst Control Center in the gaming graphics section, but that doesn't always work. The other option is to download Rivatuner, it comes with a tool called D3DOverrider. You can use that tool to force vsync for specific applications. Simply open it up, add the Witcher exe to the list, and select the option to force vsync. Simply keep D3DOverrider minimized and launch the game, and it should cap your framerate to 60FPS.


Thanks a million Supernova1138. The program seem to have done the trick. The frames seem to be capped at 60, and they very rarely drop below 30. Funny i dint think a 6670 Would be able to run The Witcher on 1080p with all the settings max out, except AA.
Score
0
Related resources
September 22, 2011 7:21:15 PM

Best answer selected by kmelaza.
Score
0
September 22, 2011 7:24:06 PM

This topic has been closed by Mousemonkey
Score
0
!