Solved

Gigabyte zx77-ud3h bios problem

Hi. I recently built my first buid and everything seems to be working fine except that I can not get into BIOS by pressing delete. Nothing happens when pressing del and windows 7 boots normally.

Pressing f8 or f12 gives me some menu with few options but it is not the BIOS! So far things are working fine but the BIOS wont load and I want to overclock etc. My specs:

- gigabyte zx77-ud3h
- gigabyte gtx 660
- i5-3570k
- 2tb wd cav blk
- 8gb corsair vengeance
- win7 home premium

Please help. (I have seen something like clearing cmos etc. But I am absolutely not familiar with that).

Thank you community.
6 answers Last reply Best Answer
More about gigabyte zx77 ud3h bios problem
  1. To clear CMOS, simply remove the CMOS battery from the motherboard (with PSU unplugged) for about one minute then replace. The system will prompt you into BIOS then to set the system clock. That's not the best way into BIOS but it may help get the keyboard to work? This may sound dumb but are you sure the delete key works on the keyboard?
    It's something anyway...
  2. Thank you. Yes. The delete key works. In fact I have tried two different keybiards, one usb and one wireless. Both are in working condition as i use them on my other pc.
    So why should i clear this cmos anyways if i presume my mobo is brand new? Thanks.
  3. I think the idea is that it may be a BIOS glitch (temporary) which would be cleared by resetting CMOS... can't really say though, it wasn't my idea (which is why the question mark in my post about fixing the keyboard).
    With a brand new motherboard though, I think I would be in contact with Gigabyte at this point, they will probably tell you to flash to the latest, greatest BIOS for "improved keyboard compatability" but since you should get into BIOS using the delete key and you are unable to, that is a problem for Gigabyte to deal with IMO.
  4. Problem solved. With this mobo, I had to press F2! Thank you all.
  5. Best answer
    I saw that as a possible option in a few posts yet your manual specifically says to use the delete key to enter BIOS, F2 isn't even presented as an option... interesting
  6. Best answer selected by xerxesaria.
Ask a new question

Read More

Motherboards BIOS Gigabyte