Solved

Dont know if psu is faulty or something else...

Hey guys im doing my first build and im having a problem...i have my motherboard and power supply and i screwed both into my case and plugged in all the wires. my case also came with a fan control box where you plug your fans into and it doesn't connect to the motherboard. I plugged my fans into it and also a molex cable which is what it gets power from. By the way i dont have my cpu yet. Anyway when i turn on my psu the fan control box does not turn on. does this mean my psu is faulty or do i need to plug the 5-pin connector from the molex cable into the motherboard? also my case is the nzxt switch 810, my motherboard is the asrock z68 gen3 fatal1ty, and my psu is a OCZ Zx series 850W modular power supply. thanks
3 answers Last reply Best Answer
More about dont faulty else
  1. Best answer
    slipmasterflex said:
    Hey guys im doing my first build and im having a problem...i have my motherboard and power supply and i screwed both into my case and plugged in all the wires. my case also came with a fan control box where you plug your fans into and it doesn't connect to the motherboard. I plugged my fans into it and also a molex cable which is what it gets power from. By the way i dont have my cpu yet. Anyway when i turn on my psu the fan control box does not turn on. does this mean my psu is faulty or do i need to plug the 5-pin connector from the molex cable into the motherboard? also my case is the nzxt switch 810, my motherboard is the asrock z68 gen3 fatal1ty, and my psu is a OCZ Zx series 850W modular power supply. thanks

    So you havent inserted your cpu?
    A motherboard without a cpu isnt going to be able to post.
  2. Best answer selected by slipmasterflex.
  3. i didn't install it and my friend from the i.t. department confirmed what you said Thanks for the help!
Ask a new question

Read More

Power Supplies Motherboards Components