Sign in with
Sign up | Sign in
Your question

Problem with XFX HD 5850

Last response: in Graphics & Displays
Share
September 24, 2011 5:08:22 PM

I just got a used XFX HD 5850(still under warranty) to replace my HD5670 from one of my friend. After I replaced the card and booted the PC for the first time, the pc booted fine and I was up and running. I shut down the pc and when i tried to restart, the pc is not even going to the BIOS. I have tried reseating the card, have replugged the power cables, reseated RAM but no success. After many tries, it once booted to windows. When i tried to refresh the windows experience index, the screen turned gray. I rebooted again but sadly could not boot to windows. In all these attempts, couple of times i also got the error " Hyper Transport Sync flood error occurred on last boot. Press F1 to resume". After struggling for an hour, i put my 5670 back in and the system booted at first attempt.

Please advise as what could be the issue here. Is it the power supply(Corsair VX450) or the GPU. I dont have another machine to test the GPU. Please help.

More about : problem xfx 5850

September 24, 2011 5:19:49 PM

I have downloaded the latest drivers, once the HD 5850 worked the first time. With HD 5670 i have no trouble, currently I am working on the system without any issues, even played BFBC2 for half an hour on 5670 just to check the system stability. And I guess, drivers would come into picture once i boot to windows, I am not even able to enter the BIOS with the 5850.
September 24, 2011 8:13:22 PM

Guys I fixed the issue.5850 is indeed a heavy card and it took me 6 hours of troubleshooting to realize what was going wrong. "Its heavy", I just screwed one screw to hold it, while it has two slots for screws and due to its weight it used to move a little in the pcie slot, which is difficult to identify,as one screw was already in. It was getting power from the auxiliary sources, but was not able to get sufficient power from pcie slot, i screwed the
other screw and voila..all is back up and running. Thanks for all the suggestions.
!