Sign in with
Sign up | Sign in
Your question

Im pretty sure my PSU is dead but need help.

Last response: in Components
Share
a b ) Power supply
February 22, 2012 9:11:16 PM

my friend replaced my PSU with one of his used ones he had laying around and it was working fine for a week. just 10 minutes ago, my computer randomly shut off and wouldnt turn on for about 30 seconds then it turned on by its self. then it turned off again a minute after boot up. then it turned on for about 3 seconds then shut off, and for some reason it powered on long enough for my lights to flash whenever i moved my desktop XD it was weird. but this is a powersupply problem right? if it is il just throw my old one back in.

More about : pretty psu dead

a b ) Power supply
February 22, 2012 9:13:42 PM

oh and btw, they both have almost the same specs, the one he threw in had a few more amps on the rails but thats it. different manufacturers too.
February 22, 2012 9:32:52 PM

You can go to the BIOS see is there has a Power monitor function in there... it will show you the Voltage on your power supply... This is not a perfect method but if your power supply really have problem it will lat least some some strange things in there...

Also is your Motherboard Capacitor in good condition?

and go to the System Event Log... to see any log in there regarding to the restart..

Related resources
a b ) Power supply
February 23, 2012 12:55:49 PM

uhm... did you read all of my post? XD my power supply will turn on long enough for the lights the flash... how the hell am i gonna get in the bios?
a b ) Power supply
February 23, 2012 12:56:47 PM

sonexpc said:
You can go to the BIOS see is there has a Power monitor function in there... it will show you the Voltage on your power supply... This is not a perfect method but if your power supply really have problem it will lat least some some strange things in there...

Also is your Motherboard Capacitor in good condition?

and go to the System Event Log... to see any log in there regarding to the restart..


oh and yes my capacitors are great even though this motherboard is 7 years old. no bulging or anyting, perfect condition.
a b ) Power supply
February 23, 2012 1:22:08 PM

Well marshal i can understand you are pissed and frustrated. But if your gonna reject everything we tell you, your not gonna get any help at all
February 23, 2012 2:37:07 PM

I only can say it has a chance on the power supply.... but unless you have a power tester or you can test the power supply in anothe system to make sure it work fine..

I see the same problem but finally is the motherboard issue... and you already have two power supply die in a row...

If the pervious powerr supply have problem and you already replace it... the prev power supply may already do some demage on the board... expecially this is a 7 year board..

If you want you can try "Paperclip trick "...http://aphnetworks.com/lounge/turn_on_psu_without_mothe...

It can show your power supply can boot up or not.... but it cannot show teh voltage is stable or not...

If it cannot pass "Paper clip trick" then 100% is the power supply dead..
a b ) Power supply
February 23, 2012 10:50:24 PM

Rockdpm said:
Well marshal i can understand you are pissed and frustrated. But if your gonna reject everything we tell you, your not gonna get any help at all


woah there, im not pissed. calm down buddy, i was joking, it was a friendly "how the hell" not HOW THE HELL?! i guess its impossible to find anyone that DOESNT take everything i say in a bad way. makes me upset that everyone instantly thinks negatively first and doesnt even consider the possibility of a human joking and being friendly to another. i even made a XD face to clearify that i was laughing and not angry, guess that isnt good enough for you.
a b ) Power supply
February 23, 2012 11:03:06 PM

Rockdpm said:
Well marshal i can understand you are pissed and frustrated. But if your gonna reject everything we tell you, your not gonna get any help at all


i dont even have a reason to be frustrated or pissed either. i have a spare one that works fine, if this one is dead then i could just throw the other back in. no big deal. so, i had no reason to be mad, even made a laughing face, and you STILL think i was being an asshole? wow.

and to the guy that was being helpful and not freaking out on me for no reason, i tried the powersupply again today, it was working fine!? wtf happend? XD (in a laughing, friendly tone as if i knew you in real life, just to clear things up for rockdpm) i even ran prime 95 and furmark for an hour while installing something to my hard drive XD no problems at all! completly stable! i installed HWmoniter and checked it, voltages are fine. so i really have no idea what went wrong, everything is working perfect. bonus for me for not having to waste 20mins to put my old power supply back in XD thanks for your time and effort anyway. sorry for wasting it XD
!