Sign in with
Sign up | Sign in
Your question
Solved

Faulty Temp sensor?

Tags:
Last response: in CPUs
Share
February 23, 2012 2:34:14 AM

Hi all,
I few days ago I noticed that my computer sounded louder than usual and traced the noise back to the cpu fan. I checked the temp using speedfan and was terrified to see my core temps idling between 95c and 100c. After going through all the likely reasons (cleaned case, cleaned heatsink and reapplied thermal grease, reset bios to default, double checked heatsink was seated properly) I saw no change at all. I've checked the temp with realtemp, speedfan and through the bios and they're all reading outrageously high. When I was checking the temp with realtemp I noticed the check sensors option and decided to give it a shot. There was almost no change in temp during the whole test. Does this confirm that there is a faulty sensor somewhere, and if so, where and how much of danger is a faulty sensor to the system?

Thanks

More about : faulty temp sensor

February 23, 2012 3:03:21 AM

It may just be a fault in realtemp... Try using hwinfo. I've noticed that most people will point to the heatsink as the culprit, if it's the stock heatsink, I'd go get a cheap aftermarket and see if it improves anything.
m
0
l
March 1, 2012 12:53:48 AM

hpfreak said:
It may just be a fault in realtemp... Try using hwinfo. I've noticed that most people will point to the heatsink as the culprit, if it's the stock heatsink, I'd go get a cheap aftermarket and see if it improves anything.


I tried hwinfo and it showed the same temps. I ordered a new heatsink and am waiting for the weekend to install it (have to take out the whole motherboard and mount the backplate). I'll post after I have it installed.
m
0
l
Related resources

Best solution

a b à CPUs
March 4, 2012 7:08:49 PM

Your CPU temperature sensors are fine. They are telling you that your heatsink has come loose. Listen to what they are telling you.

Quote:
It may just be a fault in realtemp...


See that red LOG word in RealTemp? That shows that this CPU has reached the thermal throttling point on each of the 4 cores. That data has been logged in the CPU itself and has nothing to do with RealTemp. If I had 99C idle temperatures, I sure wouldn't be doing any stress testing on my computer.
Share
a c 126 à CPUs
March 5, 2012 12:04:26 AM

Had a Core i7 860 in the shop the other day with the stock fan. Idled at 50c, load up to 100c. Tried two stock fans, same thing. Put a Zalman 9900Max, idled 30c load 50c.

Turned out the mobo wasn't holding the push pins with enough pressure.
m
0
l
March 5, 2012 3:14:09 AM

unclewebb said:
See that red LOG word in RealTemp? That shows that this CPU has reached the thermal throttling point on each of the 4 cores. That data has been logged in the CPU itself and has nothing to do with RealTemp. If I had 99C idle temperatures, I sure wouldn't be doing any stress testing on my computer.


Ya, I noticed the CPU throttling when I tested with hwinfo. Wasn't sure if a faulty sensor could cause throttling simply by reporting incorrect high temps. All the same I take you point and the computer has remind off since then. The test was a terrifying 10 mins ;)  . The push pins are also a good suspect. When I moved a few months ago the push pins actually giggled loose and when I tried to start up the computer it overheated and shut down almost immediately. I finally have some time tomorrow and I'm going to install the new heatsink. Sounds like that will probably fix this. Thanks for the help
m
0
l
March 8, 2012 2:20:55 AM

Best answer selected by squee147.
m
0
l
!