Sign in with
Sign up | Sign in
Your question

How do I update my BIOS if it is too old for my CPU?

Last response: in Motherboards
Share
December 29, 2012 6:33:01 PM

Whenever i try to install my operating system on my new pc the screen just goes black, after searching on the internet for a while i saw that someone else had the same problem, except with a gigabyte motherboard and it was because the bios was to old to support his CPU.
My motherboard is an Asus M5A97 Pro and my CPU is an AMD Phenom II x4 965 BE.
I have tries to install a new bios by putting the .ROM file onto a USB stick and trying to boot from it on my PC but instead it keep going onto the black screen again.
Specs:
CPU: AMD Phenom II x4 965 BE
MOBO: Asus M5A97 Pro
GPU: AMD Radeon HD 6870
PSU: OCZ ZS series 750W
HDD: Seagate Barracuda 1TB

More about : update bios cpu

a c 159 à CPUs
a c 435 V Motherboard
December 29, 2012 6:43:56 PM

I had good luck with asus suite II software, which includes a windows bios update flash program that you can use while running windows; no usb drive required:

Download<operating system<utilities<suite II

http://www.asus.com/Motherboards/AMD_AM3Plus/M5A97_PRO/...

Can't remember the exact procedure. You may have to download the bios file you need first and save to "documents". The suite II file is large, and includes alot of other stuff, such as hardware monitor software.
December 29, 2012 6:56:58 PM

I can't install windows to do that :( 
Related resources
a c 159 à CPUs
a c 435 V Motherboard
December 29, 2012 7:03:53 PM

If your post screen correctly identifies your cpu as the 965 BE, then the issue is somewhere else. I would try a different video card first.
December 30, 2012 12:09:08 PM

I hope it's my video card, It's the only thing I got warranty on, but are you sure? because it is fine before it black screens
a c 159 à CPUs
a c 435 V Motherboard
December 30, 2012 12:14:22 PM

How long is the black screen? I had windows 7 take forever on one board to inspect it before it even began loading. Tried a different hardrive yet? Your old drive could be also be bad.
December 30, 2012 12:27:09 PM

It black screens forever, it has got past it in the past. I'm booting ubuntu, When i click "try without installing" it stays on the loading screen forever, last time for 1 hour and when i try to install it straight away it fails at one of two things, one is failed to demonize and one is a kernel error.
I don't think it is my hard drive because i have tried two hard drives, the other was a hitachi 320GB
a c 159 à CPUs
a c 435 V Motherboard
December 30, 2012 12:45:36 PM

Got an old sempron cpu to flash the bios with? You may be right after all, or the board may have an issue somewhere. I've bought old boards with bad capacitors before. They'll post fine, but windows finds problems and won't even finish loading. But try the bios flash first if your bios file is older that he file required for the 965. Check the bios file number on the post screen. The higher numbers indicate a newer bios file. Flash the latest (on the top) and it covers all previous bios updates. You may also try loading windows with just one ram stick in the ram slot closest to the cpu; windows may be finding a ram issue somewhere.
December 30, 2012 1:02:24 PM

Ok i'll ask my friends if any have a cpu I can borrow and i'll use that to update the bios version
!