Sign in with
Sign up | Sign in
Your question

Can't get bios to display, was able too on old mobo though

Last response: in Motherboards
Share
December 29, 2012 8:02:59 PM

TL;DR: Can't get into bios, or see the splash page. Tried connecting through vga to display lower resolution, didn't work. Also tried spamming button on system boot up, also didn't work.

To start off with i'm still kind of a rookie in the computer world, but I know a few things. My old motherboard (which I can't remember the name of) fried, due to setting to high of voltages when attemtping to overclock. When I took it to frys (they have to confirm that it's dead to refund it) they said they didn't carry that model anymore and gave me an asus m5a99x evo board, which apparently had some of the same specs. When I powered it on I didn't see a bios screen or splash screen, it just booted straight into windows. This didn't really affect me at the time because I wasn't planning on overclocking until I put more research into it and figured out how to do it properly. Now, it's been around that 3 month time where I like to reformat my harddrive, and I can't for the life of me figure out how to get it to display. I tried pushing all the buttons it would be to get into it, which it does but It won't display on screen. I switched from HDMI to a dvi-vga adapter in hopes that it could display the lower resolution, which failed. I'm not exactly sure what to do at this point to reformat.

System specs:
2x 5770s
AMD phenom 965 black edition @ 3.4 ghz
Asus m5a99x evo motherboard
2x4gb corsair memory @ 1333 mhz
320gig seagate 7200 rpm harddrive
650 thermaltake tr2 rx psu
monitor (where I think the issue lies) is a toshiba 19' tv which I recycled to use as a computer monitor.


More about : bios display mobo

a c 150 Ĉ ASUS
a c 558 V Motherboard
December 29, 2012 8:20:40 PM

Hi, If clearing the CMOS, the board should wait for F1 and theoretically you should be able to access the BIOS.
m
0
l
December 29, 2012 8:38:54 PM

alexoiu said:
Hi, If clearing the CMOS, the board should wait for F1 and theoretically you should be able to access the BIOS.

The thing is though, I can get into the bios it just won't display on screen. Because if I press the key to access it, My computer won't boot into windows. I will try this later on though, If I run out of all other options.
m
0
l
!