Sign in with
Sign up | Sign in
Your question
Solved

Sabertooth Z77 Bios black screen

Last response: in Motherboards
Share
December 29, 2012 11:12:00 PM

I've recently Installed a Sabertooth Z77 and have come across a problem. Since Installation the bios screen (except for the clock portion) Is all covered In black. Mousing over the darkened areas reveals what should be displayed, but leaves It Inaccessible. Removing the card restores It to It's Intended state. My drivers should all be up to date, as far as I'm concerned anyway... I'm curious as to what could cause this, any Input would be much appreciated. My system Is as follows.

Graphics AMD Radeon HD 6790.
CPU Intel Core i5 2500
Motherboard Sabertooth Z77 (LGA 1155)

I should also note that everything works fine otherwise.
a c 150 Ĉ ASUS
a c 557 V Motherboard
December 30, 2012 12:08:55 AM

Hi, I would try updating the BIOS.
m
0
l
December 30, 2012 2:00:19 AM

My bios Is updated to 1708 which Is the current release. I also tried the previous two revisions of 1616 and 1504 to no avail.
m
0
l
Related resources

Best solution

a c 150 Ĉ ASUS
a c 557 V Motherboard
December 30, 2012 5:58:56 AM

It might be a resolution issue. What monitor are you using?
Share
December 31, 2012 6:28:34 PM

That was It. I have been running my video through my T.V. recently. I still can't help but wonder why the bios works fine without the video card on the T.V. though. Oh well, thank you much.
m
0
l
January 23, 2013 4:29:53 PM

Best answer selected by asgfsda.
m
0
l
!