Bought phenom II 945, detected as 955 BE

Hye there
How can I determine which model that I really own?
I have checked trough everest and windows, they are showing Phenom 955 running at 3.2 Ghz (phenom 945 default speed is 3.0 ghz)
I have also checked the cpu speed in bios, it also shows 3.2 Ghz.

Am i lucky? or is it just a bug in detection?

Thanks
16 answers Last reply
More about bought phenom detected
  1. cpu-z will tell you what cpu you have. you may need a bios update to identify your cpu properly.
  2. cpu z has detected the same. i will update my bios later. thanks
  3. after update, i've got cmos fail message at the start. now reverting back to old bios.
    btw, i dont think it's neccessary to update since my bios is very recent (9/7/2011)
  4. then you got lucky I guess xD
  5. Was it a new retail 945 in a box labled 945?
  6. Looks like you are lucky! See if you can overclock it like a be edition though, so you can really determine if it is.
  7. man you are so lucky
  8. loneninja said:
    Was it a new retail 945 in a box labled 945?

    i bought it on ebay. the seller said it was bought from amazon. still boxed. hopefully :D
  9. amuffin said:
    Looks like you are lucky! See if you can overclock it like a be edition though, so you can really determine if it is.

    i dont really know how the BE oc differ from normal cpu, can you please explain a bit more? i have absolutely zero knowledge about OC
  10. i tried increasing the multiplier in AMD overdrive, but when i check the speed it remains the same. not so lucky i guess?
  11. Try in bios to see if the multi is unlocked.
  12. If you bought it from ebay, rather than a retail site like Amazon or Newegg, the seller prolly screwed up and you got lucky ;)
  13. amuffin said:
    Try in bios to see if the multi is unlocked.

    i tried with the bios, however i cant find the option to change it. hmm?
    i'm using Biostar A880GZ Ver. 6.x
    http://www.biostar.com.tw/app/en/mb/introduction.php?S_ID=555&tab=3
  14. Amd overdrives a bit crap tbh, in your bios there should be something saying,
    Cpu speed 200
    multiplier x16

    can you find that on any screen in there?
    if Cpu-z says its a 955BE then I'd say thats what you have, there isn't a non BE 955 that I know of
    Moto
  15. Motopsychojdn said:
    Amd overdrives a bit crap tbh, in your bios there should be something saying,
    Cpu speed 200
    multiplier x16

    can you find that on any screen in there?
    if Cpu-z says its a 955BE then I'd say thats what you have, there isn't a non BE 955 that I know of
    Moto

    thanks man! i found it. and have successfully OC it to 3.6 (x18). afraid to go any further because of the stock cooler. thanks everyone!! i'm so happy now
  16. No problems, grab yourself an aftermarket cooler, learn how to mount it properly, and reach for 3.8/4GHz man :)
    Glad to help
    Moto
Ask a new question

Read More

CPUs Phenom