Sign in with
Sign up | Sign in
Your question

Sapphire ATI Radeon HD 5770 Prob

Last response: in Graphics & Displays
Share
September 27, 2011 4:11:40 PM

Hi All.
HELP....!!!
I have a Sapphire ATI Radeon HD 5770 1024MB GDDR5 PCI-Express Graphics Card, my mobo failed so replaced with a Gigabyte GA-G41MT-S2P G41 Socket 775 DDR3 Onboard VGA 7.1 Channel Audio mATX Motherboard, and 4GB (2x2GB) DDR3 1333MHz Memory Kit Unbuffered CL9, took the Q6600 out of old rig, but bought a Arctic Cooling Freezer 7 Pro rev 2, to install,
1st No Screen at all
2. used dvi to vga adapter, 2 lines of bios show then no display, cant even get to safe mode ect so its not driver,
3. card is under warranty does it need a rma

running Windows 7 32, on a Arctic Purepower 750 watt PSU
with onboard theres no prob, i do not have a 2nd rig to try,
i did install XP As a try, same prob.......???

STRESSED :fou:  :ange:  :fou: 
a c 199 U Graphics card
September 27, 2011 4:21:13 PM

Reset your BIOS to defaults with the jumper. If that fixes it, great. If not:
Take the HD5770 out and connect to the onboard VGA. See if you can get into the BIOS. If you can't, RMA the mobo. If you can, make sure the graphics priority is set to PCIE rather than onboard. Then re-install the HD5770 and test.
September 27, 2011 4:48:43 PM

Ok
It works fine with inboard gpu.
I installed all drivers needed.
Bios is latest.
Tried with safe options, tested psu rails.
As soon as the 2 lines of writing appear at top of screen, blM blue screen, no signal, tried another monitor aswell, also if direct dvi connect, no signal at all, through a dvi adapter 2 lines, tried hot plugging monitor, no joy, also no internal gpu available while card plugged in
a c 199 U Graphics card
September 27, 2011 10:03:05 PM

When you replaced your mobo, did you completely re-install Windows?
!