Sign in with
Sign up | Sign in
Your question

Wireless working; LAN (ICS) not working

Last response: in Networking
Share
December 25, 2010 4:54:19 PM

I'm having a problem here. Basically, for the past month or so I've been connecting to the Internet wirelessly through my laptop, then feeding the connection to my desktop PC via Internet Connection Sharing because my desktop does not have wireless capabilities. Now, seemingly out of nowhere, I am getting limited to no connectivity on my LAN connection. When I use click Repair, it says that my IP address cannot be renewed. I'm still able to access the Internet on my laptop via wireless, but my desktop is where I need to be connected. I've tried every ipconfig command that I've seen suggested (/flushdns /registerdns /release /renew, etc.), and I've made sure my TCP/IP is set to automatic, rather than static. I've also confirmed that the problem is not with the wireless network; I'm pretty sure the problem lies in my laptop. I updated my LAN drivers, but it didn't do anything.

Please help!
a b F Wireless
December 25, 2010 6:51:16 PM


If it's not possible to wire the desktop straight to the router, you might need to make sure there's a tick in "Automatically detect settings" in the desktop>IE>Tols menu>Internet Options>Connection tab>LAN button. While you're in there, check that there are no ticks in the Proxy boxes. Remove any you find but scan for malware before putting that system back online.


m
0
l
December 25, 2010 9:24:22 PM

Thanks for the reply.

On my desktop, the "Automatically detect settings" is enabled, and there are no ticks in the proxy boxes. Malwarebyte's found no malware.

My desktop is Windows 7, and my laptop is Windows XP, btw.
m
0
l
Related resources
a b F Wireless
December 26, 2010 5:13:48 AM

HarlequinForest said:

My desktop is Windows 7, and my laptop is Windows XP, btw.



Is the networking run by the Homegroup or the more conventional method and is it password protected?


m
0
l
December 26, 2010 5:21:14 PM

Saga Lout said:

Is the networking run by the Homegroup or the more conventional method


I don't know what that means.

and is it password protected? Nope.
m
0
l
December 26, 2010 5:27:01 PM

I've tried several different networks, and I have the same problem on them all. (wouldn't let me edit my post.)
m
0
l
December 27, 2010 1:07:12 AM

Alright, so I do have a USB wireless adapter (although it provides barely enough bandwidth to even browse the web), and I used it on my desktop PC to try to see if I could use Internet Connection Sharing the opposite way (desktop -> laptop). The verdict is that it does work: I have Internet on both the desktop and laptop. What implications does this have on my laptop-to-desktop sharing? Does it mean that the fault lies in my desktop after all?
m
0
l
a b F Wireless
December 27, 2010 4:25:17 AM


Windows 7 has two layers of networking - the classic method and the dumbed down one they call Homegroup. Both are pretty insistent on every machine with either W7 or earlier versions of Windows being password protected before they enable all the facilities normal networking needs.

When you set up networking in W7, youwere probably given a password on-screen and advised to note it somewhere and other machines won't be able fully to access all network services without it. Go into Control Panel>Network and Sharing and scroll down the left hand pane to Networking (past the Homegroup entry) and then scroll the middle screen all the way down to the password option and tick for no password.

m
0
l
a b F Wireless
December 27, 2010 4:26:40 AM


There's a very comprehensive Sticky Post on W7 networking by Moderator Mr. Face at the top of this sub Forum page.

m
0
l
December 27, 2010 7:05:04 AM

The password option was enabled, and I disabled it, but it did not do the trick, I'm afraid.
m
0
l
December 27, 2010 8:00:16 AM

Since you can connect your laptop to the internet by wireless connection from a router then the problem we have is down to your desktop. You said your getting limited or no connectivity on your LAN connection (this is your desktop with Windows 7 on it) - I guess it is not on the drivers or the NIC it is on the IP address.

You can say to put the "Automatically detect settings" enabled if your ISP set something to your router (IP address, sub net address, etc.) You can ask your internet provider for the numbers. It is just the settings.
m
0
l
December 27, 2010 3:51:17 PM

Well, actually I can connect my desktop to the Internet by wireless connection (via USB adapter) as well. The limited or no connectivity actually shows up on BOTH computers whenever I connect them together with an Ethernet cable, not just the desktop (except when I share the connection from my desktop to my laptop, rather than laptop to desktop).

"You can say to put the "Automatically detect settings" enabled if your ISP set something to your router (IP address, sub net address, etc.) You can ask your internet provider for the numbers. It is just the settings."

Sorry, what do you mean by this? Do you mean to set up a static address?
m
0
l
December 27, 2010 4:00:18 PM

Maybe we could just do a straight-up bridge? Go into Network Connections (Adapter Settings in Win 7/Vista) and highlight both the LAN and WLAN connections on the laptop. Right click, "Bridge Connections". You will have to disable ICS before you do this. This will turn you laptop into a network bridge.

You may also want to try setting up static IPs on both machines to be sure it's not an addressing problem. Make sure they're on the same network. Set one as 10.0.0.1 and the other as 10.0.0.2. Subnet mask is 255.0.0.0. The desktop should have the default gateway listed as the IP of the laptop. DNS can be set to 8.8.8.8 and 8.8.4.4 (Google DNS, always works, super fast name resolution).
m
0
l
December 27, 2010 5:30:49 PM

Tried the bridge, but lost all connectivity (even wireless).

Set the static IPs up on both computers, but I don't know what I'm supposed to be looking for as far as seeing if it's an addressing problem or not. Is the LAN supposed to be static, or the WLAN?
m
0
l
December 27, 2010 6:49:16 PM

Oh, man. This is a nightmare. Now my laptop's wireless connection is getting limited or no connectivity, saying, "The RPC server is unavailable.

edit: Well, that problem was solved upon reboot.
m
0
l
December 27, 2010 7:13:29 PM

Yay, it's fixed! I changed the network from a public network to a home network. I personally have no idea why that matters (but I'm sure you guys do), but I do remember changing that around sometime before I was no longer able to connect. Thanks for the help, guys!
m
0
l
!