Sign in with
Sign up | Sign in
Your question

ATI 6970 Fan speed issue

Last response: in Graphics & Displays
Share
September 29, 2011 7:59:18 PM

For some reason my fan speed are always around 27-30% even when im gaming and the remperature reach 60+ it gets to a point where the whole PC freezes i dont know why but for some reason CCC thinks 70+ should be 30% is there anyway to fix this?
September 29, 2011 9:13:34 PM

Don't know if you can adjust it with ccc, i thought so, but i can't rememeber. You can download something like msi afterburner or evga precission and make your own fanspeed curve settings. 60-70 is not that much btw and shouldn't make the system crash.
September 29, 2011 11:00:03 PM

You can set the speed manually in CCC -> Overdrive. 60-70 is nothing to be concerned with and really shouldn't be causing any issues.

[Edit] correction you need to go CCC -> Performance -> Overdrive
Related resources
September 30, 2011 5:29:05 AM

I know i can set it manually but itsjust a hassle doing it everytime, is there anyway to fix this issue. @robjordy it gets higher than that but i can't even see the temps beacause im in full screen but when i touch the care its super hot! No way to fix apart from setting manually?
September 30, 2011 5:43:25 AM

Could always swap out the cooler on it.... Open/Unlock the overclocking in CCC and set the fan, I just did because I upped the voltage in the bios...
September 30, 2011 6:15:56 AM

are you sure that the crashing is caused by your GPU?

could be almost anything without some more info.

temps look fine tho.
September 30, 2011 2:34:09 PM

It's gotta be the GPU beacause if i set the fan speeds to 80% and play bf3 it doesnt crash after awhile.. what else could it be? is there no software that can check the temps and increase the fan speed acordingly?

i cant actually see the temps it gets to beacause it crashes with pixel lines
October 2, 2011 10:37:31 PM

Sapphire TRIXX will do it is quite easy to use.

Is your system overclocked?

I assume Win7?
Right click My computer,
Properties, Advanced System Settings
Click the Advanced tab and startup & recovery button
TURN OFF AUTOMATIC RESTART after error.

this will atleast give you a chance to write down the error code and we can find out from there.

Have you tried updating your video card drivers?
December 29, 2011 6:04:41 AM

I have the same graphics card and had the same problem but solved it.

It's very easy with Catalyst Control Center. In CCC go to Performance > AMD Overdrive, check Enable Manual Fan Control and set to 40 or 50% (50% if you want to play it safe and if your case is fairly well cooled already).

That seems to be the golden ratio for keeping the gpu temperature stable and around 60C when the card is under 100% gpu load for me).
!