Constant abnormal ping spikes in-game, Help! [FIXED]

Hi everyone, i've been having an problem with my internet when playing games that has been unresolved for about 6 months now..
Whenever i'm playing a game, most noticeably Bad Company 2 or Mount & Blade: Warband i'd watch my ping in the scoreboard carefully spike from under 100ms to 300+ms and back down quickly, slow enough though for me to notice the spike in the gameplay.

The things I have done so far are:
* Line quality tests @ http://www.dslreports.com/pingtest/62b4cc567ab9/2707472?r=439
* Ping tests @ pingtest.net
* Speed tests @ speedtest.net
* Disabled Punkbuster in services.msc
* Disabled Bonjour (Apple service) in services.msc
* Toggled TCPOptimizer settings from Default to Optimized, no change, changed back to Default to be safe.
* Ran NetLimiter to see what is potentially using up bandwith causing ping spikes (found nothing)
* Updated my motherboard's BIOS
* Updated my Realtek 8111C LAN driver
* Updated my audio drivers
* Directly connect my modem to my LAN network card (faster internet speed but ping spikes still constant)
* Tweaked my "autotuning settings" (http://support.multiplay.co.uk/index.php?_a=viewarticle&_m=knowledgebase&kbarticleid=64#rubberbanding)
* Tweaked my NIC's settings in Device Manager
* Switched my ethernet cables (Cat5e)
* Virus scan with Comodo, Avira, and Malwarebytes Anti-Malware. Found nothing unusual.
* Disabled anti-virus and firewalls when playing in-game, results still did not differ.
*Upgraded to Windows 7 64-Bit

Things I have yet to do to try and solve the ping spike problem:
* Tweak Hard Drive settings in Device Manager
* Buy a new Gigabit Network Switch to be aquire Gigabit speeds (If that'll do anything for the ping)
* Buy a new Hard Drive
* Upgrade to 4 GB of RAM
* Buy a new Intel Pro CT 10/100/100 NIC (LAN Port) -"I've got my best hopes on this to solve it"
* Re-install Windows 7 in 32-Bit and start fresh again.. -"Last resort and most unlikely to solve the issue as even reverting to Windows XP didn't work"

Test results :bounce: :
http://www.pingtest.net/result/30902844.png
http://www.speedtest.net/result/1085034237.png


My computer hardware is as listed:
Gigabyte MA770-UD3 rev 2.0 *Motherboard
AMD Phenom II X4 955 BE @ 3.2Ghz Stock Speed *CPU
3 GB DDR2 667Mhz Kingston *Memory
XFX HD 5750 1GB 700Mhz 1150Mhz *Graphics Card
D-Link WBR-1310 rev D * Router
1280x1024 Acer LCD *Monitor
Windows 7 32-Bit *OS

Can anyone help me? Any suggestions, im open to take all the help I can get please!
This is the first time this problem has occured to me and it's quite unusual! :cry:

Sincerely Chris,
Happy Holidays & Merry Christmas by the way!
2 answers Last reply
More about constant abnormal ping spikes game help fixed
  1. Fixed my own problem, it was the cable splitter that splits what runs from my modem and television to the outlet. I seperated them and directly connect my splitter, typed "netsh winsock reset" in Safe Mode with Networking, reset my computer and the ping spikes that burst from 21ms to 900+ms when pinging Google.ca vanished. What a miracle Shaw tech support has done for me, gaming is a go again!
  2. Ha ha ha, congratulations - enjoy your game.
Ask a new question

Read More

Networking