Sign in with
Sign up | Sign in
Your question
Solved

[SOLVED] MOBO not reading all memory

Tags:
Last response: in Memory
Share
January 3, 2013 10:01:48 AM

So I just built a computer and realized while goofing around that my memory was at a high usage while multiple windows were up. I checked my BIOS and looked at the DDR3 memory slots and it says I only have 4096MB in each slot where my sticks are. I have two Kingston hyper x genesis 8GB 1600Mhz sticks in it. I dont unserstand why my motherboard is only seeing it as 4GB sticks instead of 8GB sticks.
The mobo is also running the ram at 1333.

Any ideas as to why it is reading like this or how to change it.

I have a the following build:
Cooler Master something case I got for free
Asrock Pro 3 Z77 - mobo
i5-3570k - cpu
stock heatsinc and fan
PowerColor Radeon HD 7770 - graphics card
1TB Hitachi - hard drive
StrikeX 600W - PSU
Windows 7 64-bit Home Premium

Also I have tried the CPUZ and says the same due to the fact it reads off the BIOS, clear the cmos and move all the sticks around on the different slots as well as individually leaving the sticks in a slot.

Best solution

a c 251 } Memory
January 3, 2013 10:28:42 PM

Check for BIOS update for your board.
Share
January 4, 2013 4:30:14 AM

Okay I solved it. I went back to the place I bought the RAM and they told me because its a kit that it says 8GB on the stick but that means two 4GB stick kit.

Sorry and thank you all.
m
0
l
January 11, 2013 5:08:22 AM

Best answer selected by PoePoe8924.
m
0
l
!