Sign in with
Sign up | Sign in
Your question

Hard Drive not labeled as c drive?

Last response: in Components
Share
February 29, 2012 2:42:34 AM

I have a dell vostro 200 with Win XP Pro. Simple setup with one harddrive, and 2 cd/dvd drives. Hard drive failed, I just installed new western digital harddrive, initially works ok, hard drive formatted, windows xp started up.
Now trying to reinstall drivers off original cd from dell, one step is to set up folder in C drive for drivers, but computer says can not create the folder. I look at 'My Computer" it says the hard drive is the "i" drive and my 2 cd/dvd drives are g and h (instead of c as hard drive, and others as d and e)
How/why does the computer label the hard drive as i?
February 29, 2012 1:33:19 PM

I would disconnect all the other devices except the new drive and reboot. Then connect one optical drive while windows is running. Windows may also ask to format the new drive, which is fine. Then reboot with the dell dvd inside the optical drive and proceed with your installation.
m
0
l
February 29, 2012 9:35:57 PM

SATA nor IDE aren't hot swappable, meaning it wont work if you plug it in while the machine is running, just try with one ODD drive, with the disk in, or go into disk partitioner in windows and relabel the drive from there. I find that relabeling is the easiest option :)  if another drive is using the letter C just change that first ;) 
m
0
l
Related resources
February 29, 2012 10:19:51 PM

You know you could re-order your drives and make "i" C.
m
0
l
March 1, 2012 6:03:01 AM

Edit the letter labels using widows disk partitioner, goto: Start/run/diskpart then right click on the drive whos letter needs changing, select the option 'change drive letter and paths' then select the letter of the drive, now an 'edit' option is avilable, click that, then choose the new letter (C) in the menu that comes up, don't forget to apply changes, it may ask to restart pc, if it does, choosing to not restart it will only mean that the letter wont change until you have restarted it manually :) 
m
0
l
!