Sign in with
Sign up | Sign in
Your question
Solved

Overclocking 6950 Doesn't boost performance, at all.

Last response: in Graphics & Displays
Share
October 1, 2011 5:07:54 AM

So, I have an MSI HD 6950. Unlocking the card's hidden shaders boosts 3D Mark 11 score from X1617 to X1672, under the "Extreme Level" preset.

Overclocking (with boosting voltage or without) has no effect on scores, FPS in games or smoothness. Just doesn't make a damn difference.

Any thoughts? I know people always said that overclocking a 6950 can get it to match the performance of a 6970... I don't see that.


Some benches with cores unlocked:

1x 6950 950/1400 @ 1.19V - http://3dmark.com/3dm11/1921245
1x 6950 925/1400 @ 1.19V - http://3dmark.com/3dm11/1921201
1x 6950 880/1375 @ 1.18V - http://3dmark.com/3dm11/1921145
1x 6950 800/1250 @ 1.10V - http://3dmark.com/3dm11/1921086

Don't pay attention to the GPU clocks in the benchmark readout. It reads clocks from the AMD drivers, while I overclock using MSI Afterburner.
a c 217 U Graphics card
a b K Overclocking
October 1, 2011 5:46:31 AM

According to the score read out, every benchmark was done at 800mhz core and 1250mhz memory. (Stock 6950 settings).

Are you sure you overclocked it?
m
0
l

Best solution

a c 217 U Graphics card
a b K Overclocking
October 1, 2011 5:48:08 AM

I've used MSI afterburner with my 6950, and had no such problem with the read out. You need to disable CCC. MSI afterburner and CCC don't play nice.
Share
Related resources
October 1, 2011 5:48:48 AM

bystander said:
According to the score read out, every benchmark was done at 800mhz core and 1250mhz memory. (Stock 6950 settings).

Are you sure you overclocked it?


I used MSI afterburner to OC. Catalyst drivers will NOT see the overclock, which is where the benchmark collects its data from.
m
0
l
October 1, 2011 5:49:22 AM

bystander said:
I've used MSI afterburner with my 6950, and had no such problem with the read out. You need to disable CCC. MSI afterburner and CCC don't play nice.


how do you do that?
m
0
l
a c 217 U Graphics card
a b K Overclocking
October 1, 2011 5:53:08 AM

solomonshv said:
how do you do that?


You can hit ctrl-alt-delete and kill the task CCC.exe to stop it and then test. You'll also have to make sure MSI afterburner has set the clocks. Have you check the running clocks on the right of MSI afterburner? It should have shown you the problem there.

Next, to prevent it from starting up at windows start up, you'll need to open up the command prompt (run cmd) and type in msconfig. Go to the startup tab and remove CCC from the list of programs to start when you reboot.
m
0
l
a b U Graphics card
a b K Overclocking
October 1, 2011 5:54:18 AM

what cpu do you have ?
m
0
l
October 1, 2011 5:55:19 AM

bystander said:
You can hit ctrl-alt-delete and kill the task CCC.exe to stop it and then test. You'll also have to make sure MSI afterburner has set the clocks. Have you check the running clocks on the right of MSI afterburner? It should have shown you the problem there.

Next, to prevent it from starting up at windows start up, you'll need to open up the command prompt (run cmd) and type in msconfig. Go to the startup tab and remove CCC from the list of programs to start when you reboot.


OK. I'll give that a whirl. Maybe this will stop my random Stacraft2 and Crysis2 BSOD problem too.
m
0
l
October 1, 2011 5:55:55 AM

spentshells said:
what cpu do you have ?

i5 2500K @ 4.0Ghz. It's in the benchmark readout.
m
0
l
a c 217 U Graphics card
a b K Overclocking
October 1, 2011 5:57:02 AM

BTW, the problem with CCC and MSI afterburner seems to only effect the 6900 cards. Probably due to the PowerTune setting.
m
0
l
October 1, 2011 7:12:48 AM

Best answer selected by solomonshv.
m
0
l
October 1, 2011 7:17:01 AM

bystander said:
BTW, the problem with CCC and MSI afterburner seems to only effect the 6900 cards. Probably due to the PowerTune setting.


Yep. Looks like you are right. Disabling CCC did the trick. It's strange that Afterburner reported the overclocked speeds and the fans revved up after applying the overclock, as if it registered. And this was never a problem with the nvidia cards I played around with... but like you said, could be a powertune thing.

Anyway, new benches:

1x HD 6950 unlocked 900/1400 @ 1.15V - http://3dmark.com/3dm11/1921697 went from X1672 to X1842
2x HD 6950 unlocked 900/1400 @ 1.18V - http://3dmark.com/3dm11/1921865 X3532, CF scales by about 96%

One curious thing, when in crossfire, I had to bump the voltage on both cards from 1.15V to 1.18V, which is the stock voltage of an HD 6970.

The cool thing is that my bench for the single unlocked 6950 outpaces what most people get on their 6970, according to 3D marks website. Also comes close to a single GTX 580.

Thanks.

Now, if only I could do something about this microstutter thing.
m
0
l
October 1, 2011 7:35:47 AM

I use sapphire trixx because msi afterburn does not let me overclock more than 840 and 1350.
m
0
l
October 1, 2011 7:51:15 AM

erasmo84 said:
I use sapphire trixx because msi afterburn does not let me overclock more than 840 and 1350.

it does, but in order for it to allow you to do so, there is a file you have to modify.

In the install directory for MSI Afterburner, you have to find the file "MSIAfterburner.cfg"

in it, find the line "UnofficialOverclockingEULA = 0" and charge it to "UnofficialOverclockingEULA = I confirm that I am aware of unofficial overclocking limitations and fully understand that MSI will not provide me any support on it"

and right below it, change "UnofficialOverclockingMode = 0" to "UnofficialOverclockingMode = 1"

then you are good to go.
m
0
l
!