Sign in with
Sign up | Sign in
Your question

Crossfire No Longer Working

Last response: in Graphics & Displays
Share
October 1, 2011 7:09:20 AM

I've got two 5850's, XFX Black Editions. Things worked great forever. I've actually taken a break from gaming for a while, and haven't really utilized my cards in a while, so there's no telling really when this may have started.


First, I have a TV HMDI'd to my second card (when I try to run dual display out the the HDMI in my main card, nothing shows up. Monitor on DVI). The other day the image kept flickering on the screen... Not continuously, only after you would rest the mouse a minute. A minor mouse movement would cause it to stop. I restarted, all was well.

Now, I get flickers from my main monitor, typically when I do ANY type of software install or upgrade, and sometimes when I load a game. The first thing I did to troubleshoot was restart, which always worked, but it always came back, so in the middle of the flickers I disconnected the HDMI from the second card, and it stopped.

I recently downloaded the new Battlefield 3, and noticed my frames couldn't possibly be as low as they were... Crossfire was enabled... I tried disabling it, got the exact same frames. So I ran the Heaven benchmark to be sure, with CF on and off, and the results were identical.


My second card "works" just fine, I can plug another display into it and there are never any blue screens or errors, but all of a sudden the flickering started, and now (like I said I haven't gamed in a while so I don't know if this happened together) Crossfire is not working, at least, it's getting me 0% improvement.


I'm hoping someone has some info before I start swapping cards and blah blah. The flickering did actually happen after a driver update, but I've since updated again to the most recent Catalyst drivers that came out a dew days ago. Same stuff. Is there a known problem with newer drivers and the 5xxx models?

Hoping I don't have to start breaking things down to troubleshoot. Any suggestion is great. Thanks.
October 1, 2011 7:11:13 AM

Oh and I noticed the temp/processing clocks in CCC read all 0's on my second card, as if it's off. My first CF rig, so don't know if that's normal.
m
0
l
October 1, 2011 2:03:40 PM

Got it to work for a bit. I noticed I couldn't even get the fan to rev up with manual fan controls at 100%, as if the card is "off" or I can't communicate with it. Turning CF on and off again I got the card to work, finished a satisfying benchmark, then poof, she shut back down.


It's as though there's something shutting down the card.
m
0
l
!